Unable to set up DEVONthink to go


I have just bought both Devonthink pro and to go, and have problems setting it up so that I can reach the database from my iPad or iPhone; I only get a “bonjour failure” and cannot see my Mac on either of the devices. I am sitting on my own (open) wifi network, with my phone connected to the computer - it can still not see it.

Maybe I need to do something inside Devonthink to set this up? I have tried to place items in the to-sync folder, but this makes no difference.


I would start by rebooting both devices.

Thanks for the suggestion. I have done so, but nothing changed - in the sync window (on the devices), there is no computer visible on my network. I have disabled my firewall, so this is not the reason.

Do I need to do anything in particular in the Devonthink program?

You shouldn’t need to. I would try setting up an ad-hoc network on the Mac, connect the mobile device to the network and see if that changes it.

Nope, did not change anything. Nor does anything change if I connect to the computer with a wire.

Try deleting DTTG and reinstalling it.

I also have the same problem. I have had DT Pro Office for a while now with the current version 2.7.1.
Today I also downloaded DT to go 1.4.1. and I was able to import only two files from my DT desktop computer. After that, each time I tried to sync between two devices the sync would last for a fraction of a second and nothing would be imported into DT to go…

I have now tried to reinstall both DTTG and Devonthink pro. No difference, I still get a bonjour failure, seeing no devices to connect to, and am not able to reach anything from my database.

I have also tried at another network, but this does not make any difference either. There must be something preventing bonjour to work.

If the connection to the Mac fails it could well be the router interfering. Please try to create an ad-hoc Wi-Fi network with the Wi-Fi menulet. Then connect to that network from your iOS device and try if syncing works now. If it does then your router is somehow interfering with the connection.

No, this did not help either - I can still not connect. I am running Mavericks - can that be the reason?

I just synced a database from my MacBook Pro running DEVONthink Pro Office 2.7.1 under Mavericks, to DEVONthink To Go 1.4.1 on an iPad Air running iOS 7.0.3.

I wanted to sync a fairly small database to the iPad, so moved the database into the Mobile Sync group.

Here are the steps I took:

  1. Set both the Mac and the iPad to the same WiFi network.

  2. Launch DEVONthink To Go, then press the Sync button.

  3. On the iPad, select the Mac when it is recognized. Then, on the iPad, enter the 4-digit number that’s displayed on the Mac.

  4. On the iPad, in the list of databases available for sync, click on the one(s) to be synced. A checkmark on the database(s) to be synced will then be visible.

  5. On the iPad, click on ‘Synchronize’ and sync will start.

The sync was successful.

Sounds great to me - and that is what I assumed when I bought it. However, I have problems when I reach step (3) - there is nothing to sync with; there is nothing to select, the list of available devices is simply empty.

Also, on the Mac, I can see in the log that bonjour has failed to connect - so the Mac is clearly “reached”, but it still fails.

DTTG seems just like the product I was after, so it is rather frustrating when you buy it, install it, and then nothing works…


I now tried sync again - for the x:th time - and all of a sudden it worked! :open_mouth: I have no idea why it now worked, I did not change anything, but it seems fine now… :question:

I still have a similar problem. I am able reach point 6 above but the sync would last for only a fraction of a second and nothing gets transferred… I tried it on two different wireless networks.

Did you move or replicate the items to be synced from the Mac into the database Mobile Sync group?

Did you select that database as in my step 4), so that a checkmark is then visible for that database?

I forgot to replicate data to a mobile sync folder… my apology.
Thank you for your help.

I’m having exactly the same issues. Have run through the trouble-shooting checklist. Very frustrating.

I did the same in the sense that I bought the program a few years ago and never got it to work. Yesterday I tried, after a long time not trying again, and it worked. Today I’m super frustrated because nothing worked after trying all of the suggestions made. Same network as yesterday no changes at all.
What surprises me is that I use a lot of synchronization programs from notebooks to Evernote and they all work all-the-time. So I’m so surprised that at Devonthink writing one of Mac’ best programs you’re unable to deliver this level of simple synchronization. I’m sure you have throusands “screaming” for this so when can this be resolved?