Unresponsive / Spinning beachball

Hi All,

I have just bought DevonThink Pro Office, based on a number of positive reviews.

Since then, I get nothing but spinning beach balls on my MacPro… The (tiny) DB is sitting on a Drobo (tons of free space.)

I have (finally) managed to import so files into DT, but moving from global inbox to a database inbox (for example) will leave the program unresponsive with a spinning beachball for minutes on end.

I am really trying to work with DT, but, at the moment, this is totally unusable.

Any help, tips and advice to try would be greatly appreciated.

Paul :cry:

Is it really a DEVONthink issue? Is there a slowdown issue in transferring files from the Global Inbox to the database, if you move the database to the computer’s internal drive, or even to a mounted USB drive?

I agree with Bill. This sounds very odd, especially for something as powerful as a Mac Pro. It seems to me that trying a bunch of configurations to isolate the issue would be the best way forward. I’ve had databases on external drives with no problem using my Macbook Pro. If you try different scenarios and they all come up bad in the end, it might have something to do with DT on an MP, since that is a relatively rare combination (more MBPs out there than MPs), but that would probably best be diagnosed with support.

FWIW - in three(?) years of use, can count on 1 hand the amount of times DTPO was unresponsive- and always fixed with a restart. I realize that doesn’t help you - but must add to what was said above - something else is probably happening to cause the slow-down. Good luck finding it, else reach out to Support!

There is one time I almost always get a “beach ball” and then a red text saying file not found.

It is when I have very unstable internet. When it comes and goes. I am traveling 300 days per year and sometimes the internet is just barely working. If it is steady slow no problem, but if it turns off and on it happens all the time.

Simple solution - just turn off WiFi and Devonthink works perfect again.

Not sure if this has anything to do with your problems - just a thought.

DEVONthink does lots of file access switching databases. Drobos have a lot of space, but tend to be slow. Try an experiment moving the database to an internal drive, preferably an SSD if you have one.

I have the same problem - the spinning beachball for most right click shortcuts like copy, set name as, and others. It stops my work flow. I’ve tried Verify and Repair/Optimizing and Backing up. No help.


I’m using DTOP. 16GB of RAM on a 2009 iMac.

Sorry a couple of things I forgot to mention, my databases are DT Indexed on the iMac HD. So the iMac could be part of the problem. I recently ran Disk Utility on it. My memory app shows around 20-30% free all the time.

A little more info, please. Does this mean that you are using DEVONthink on a different machine (the "DEVONthink machine) than “the iMac” and you are indexing files stored on “the iMAC” from the “DEVONthink machine” – IOW you are connecting to your data sources via Bonjour, or other method, on your local network?

Re Korn questions: 1. No the DTOP databases are on the iMac HD. The data is also on this drive. E.g. In Documents I have a research folder where I store pdfs. Then in DTOP I have a database that is indexed to that folder to search within it. Does this make sense? They are close together in Documents folder. Path: Documents/Research folder. Then Documents/Research DB.
2. Another example, when I download a pdf into Downloads folder I usually move it to the Research folder. Then periodically I update the Research database by Indexing it.
But still the problem remains, spinning beachball for simple right click shortcuts as previously mentioned.
Is the problem the Research folder is next to the Research DB?

BTW I also have external HD where I save my media data. And another one to which I do backups.


This is unfortunate. The behavior you report is not common. I suggest you open a ticket directly with Support (here or here or support_at_devontechnologies_dot_com), where you can get faster personalized attention than the forum. Please save relevant console messages, and DEVONthink crash logs, and forward them to Support.

There are variety of increasingly complex recovery procedures. You could also try DEVONthink > Empty Cache. If you want, you could delete and reinstall DEVONthink (rebooting between de-installation and re-installation). Or also quit all programs, shut down the machine, and boot into Safe Mode. In case there is a permissions or disk error, you could attempt using Disk Utility in Recovery Mode.

Hello Korm,
Thanks for the feedback.
To give you an idea of the time the ball spins after right clicking - it often spins 15 seconds.

I was having the same problem every few items I clicked on and turning off the wifi solved it. I do have a network sync setup - even though the target machine is asleep. Probably trying to make a connection?

Sync attempting to connect to another machine shouldn’t stall the app. Is this a very large database, in terms of the number of words / unique words? Check File > Database Properties >.

Could you please launch Apple’s Activity Monitor application (see Applications > Utilities), choose DEVONthink in the list of processes, click the “Sample” button in the toolbar while DEVONthink isn’t responsive and send the result to cgrunenberg - at - devon-technologies.com? Thanks in advance!