Updating of indexed folders

Hello there,

I am very new to DT3 and I am encountering a problem that I think is probably just me making some weird mistake - but I searched the forum and I couldn’t really find a possible solution to my problem other than what I read here in another thread from june 2019 where a broken database was the issue.

However - I have a folder indexed. It is a document folder containing almost only PDFs concerned with my thesis. If I add a new PDF to this folder, my understanding is that it should update in the DT indexed folder. But this doesn’t happen. Using the File > ‘update indexed folder’ command also does not do anything. Currently I kinda manually index the new file by hand but I think that’s not how it is supposed to work.

I wonder if I am overlooking something really stupid (“The problem is that it is the ICloud documents folder”) or if I misunderstood how it is supposed to work…

And yes, I am also looking for answers in the handbook, just not successful yet.

Thank you for your time and patience :slight_smile:

What’s the path of indexed folder and which version of macOS do you use? Does rebooting the computer make a difference?

Rebooting does not make a difference.

But maybe it is the fact that it is an iCloud folder.

icloud > documents > Thesis Literature > Journal PDFs is the path shown at the lower edge of the finder.

Do you add PDFs to this folder on the same or another machine?

Folders located on iCloud Drive and indexed into DEVONthink should work perfectly. I actually index 100% of documents in my DEVONthink databases, and all the indexed documents are in iCloud Drive folders.

Do you perhaps have the macOS ICloud Drive preference set to store documents in iCloud to where they will only be downloaded on demand to your Mac? Just speculating, but that could possibly explain why they are not being indexed into your database. What happens if you move an imported document into the indexed group in your database, does it get exported to the respective folder in the Finder?

1 Like

Same machine, no other device, no sync via devices currently.

macOS 10.15.6

I am going to check & change the settings of iCloud tomorrow and see if it does anything.

If an indexed folder in iCloud Drive has a cloud with a downward facing arrow icon, Control-Click it and download it so it’s local to the machine. Then make changes to this folder and see if the changes propagate to DEVONthink.

Wanted to give you some feedback. Issue is solved. Documents in my indexed folder appear rather switfly.

Things worked out for me but I don’t know exactly what did the trick. Whoops.
I did:

  • Cleaning up the bin and permanently deleting doubles. I think some of the indexed folders have been deleted by me and re-indexed and I read in another thread that this might cause issues
  • My preferences were indeed storing documents in icloud and only downloaded when needed. So I changed that.

One of those - or both combined - fixed the issue.

Thanks for your help!

Glad to hear it and you’re welcome :slight_smile: