Upgrade to Leopard breaks import folder actions

Since upgrading to Leopard, the import folder action script no longer works. I checked Configure Folder actions and “Action Import.scpt” is checked “on”. How do I fix this?


Hi, Karen. My Folder Action folder to Import content to a DT Pro database still works under Leopard, although the new content in the database may take a while to appear. New items will be sent to the top level of the database.

If you use the Folder Action script routine on an existing file on your hard drive, the creation/modification date will not be changed. So if you are sorting by Date Modified an old 2005 document will not show up at the top of the sort list. :slight_smile:

If your script seems to have stopped working, try deactivating if from the folder to which it was attached, then attach it once more and test.


Great so it’s me! :blush:

I tried your suggestion, plus repair permissions and restart, and had no love. I checked the console log and found this message:

1/4/08 4 3:16:11 PM com.apple.launchd[117] (com.apple.FolderActions.folders) Throttling respawn: Will start in 2 seconds

I have no idea what that means. I waited much longer than 2 seconds and nothing was imported.



Karen, do you by any chance have 1PassWord installed?

I did a test of it today and saw a lot of those “respawn” messages in the Console. And Folder Action Import took a long time for content to be added.

I’ve since removed 1PassWord from the Input Managers folder and everything seems back to normal. And the Folder Action Import script works quickly. This isn’t conclusive that 1PassWord causes problems. I’ll do more testing.


I found my problem. The Action Import.scpt was missing from /Library/Scripts/Folder Action Scripts. It is there on my extra external harddrive where I’ve kept my bootable Tiger clone. I did an Archive and Install, so it must not have copied over.

The respawn problem may be a bug in Leopard. MacOSXHints has a discussion on it. http://forums.macosxhints.com/showthread.php?s=3f8102fe3f179eafce5bf58a3adf8efd&t=80931 That’s all a little over my head.

Thanks for your help!


Things were happy for a while, imports were zippy, but then I began to experience delays of about 3mins whenever I used the FolderAction Import Folder. Deactivating/Reactivating scripts did not help. So, I deleted the old folder, removed it from the list in Configure Folder Actions, created a new folder, reattached the Import Folder Action, zippy imports again!

I also had problems with a rotate image folder action, but it stopped working completely (OK, I waited ten mins and then I gave up). Same fix solved that problem.

Is it just me or are folder actions buggy under Leopard? I never had problems with Tiger.


I had constant hangs, lockups and issues when I switched to Leopard. I tracked it down to something folder actions-related and disabled them. Things have been MUCH better since.

I figured it was specific to my system as I didn’t see other folder action-related issues posted anywhere.

I liked using folder actions but haven’t tried enabling them again.

I also see frequent LS related console entries. I use Leopard Cache Cleaner to rebuild and relaunch the LS database on occasion.

I do have 1Password installed though I haven’t tried removing it.