Use of DevonThink 3 with Fujitsu ScanSnap Home: files not installed in DT3

I was using ScanSnap Manager to take files from my ScanSnap iX500 scanner and put them into DEVONthink Pro for processing and integration into my database. Everything worked well.

Then Fujitsu announced ScanSnap Manager would no longer work, that I must upgrade to ScanSnap Home to continue using my scanner with my MacPro.

At the same time, DEVONtechnologies announced that I could no longer use DevonThink Pro, so I had to upgrade to DEVONthink 3. So I did that too.

Now, after hours of effort, I have configured ScanSnap Home to pass the scan to DEVONthink 3. I see the little window that says it is “Adding document…” but it never adds it no matter how long I wait.

I am struggling to make two separate applications from two different companies work together and there is no guidance in the Help sections that I can find. I have a rising stack of paper to scan, an extensive DEVONthink database that I can’t abandon, and a scanner rendered useless to get files into my database.

What do I do now?

Did you see this Configuring Devonthink Pro 3 with Scansnap Home / ix1500 - DEVONthink - DEVONtechnologies Community?

Please post screenshots of your ScanSnap Home settings.

I followed all the steps described in the article you mentioned, and ScanSnap Home now sends scans to DEVONthink 3, but they join a queue of other scans: each display the message “Adding document”:

Then I noticed that the author’s scanner an s1500 wouldn’t work with DEVONthink3/ScanSnap Home and he had to buy a new scanner. You will note that mine is an ix500, not 1500. In any case, the scans were showing up in ScanSnap Home before I followed the instructions. Now they’re being sent to DT3 but are stuck “Adding document.” for several days.

Where do I go from here?

Unfortunately I can’t answer that (at the moment). When you first posted I just installed my SV600 the day before, so I thought it would be easy to help, but seeing your ScanSnap Home screenshot I’m afraid ScanSnap uses different ScanSnap Home versions for different scanners - altough I can’t believe that they’re that different. Are you sure this screenshot was taken in ScanSnap Home and not in ScanSnap Manager?

I’m sure there will be a way to get it working, from the Fujitsu website:

ScanSnap Home is compatible with ScanSnap iX1500, iX500, iX100, S1300i, S1100i and SV600.

Could you please post screenshots of the other preferences tabs too?

Which macOS are you using? If Catalina, does DT have access to the folder in which ScanSnap Home saves scans? Like so:

(or full disk access, which presumably also works and which is required for some functionality in DT)

FYI: I use ScanSnap Home and an ix500, and all is fine - so the combination is definitely compatible; assuming you followed the steps outlined in the post which pete31 linked to, your setup should be correct; it’s possible you missed the system dialogue asking you to permit DT to access the documents folder, at which point the dialogue expired and DT has no access rights - which I guess would lead to exactly the behaviour you are describing)

Thank you for your quick response. The screenshot was from DT3 showing the current state of affairs including the “Adding document” messages in the lower left corner. I did not provide the other settings screenshots because the DT website only lets new users upload 1 picture. I will attempt to send the ScanSnap Home settings screenshots now:

Unfortunately, I’m still restricted to 1 file uploaded at a time.

Thanks again!

Following the advice of the succeeding post, I made sure Fulfill Disk access for DT was assured:

But now I’m getting no feedback from DT3 that a scan was received.

And I’m currently using Mojave 10.14.5; been waiting for upgrades for my many apps before switching to Catalina on my Mac Pro connected to the scanner.

@BLUEFROG could you take a look? @Reynsaunders’s ScanSnap Home version is different than mine so I don’t know what might be the problem.

I’m sorry this is turning out to be so difficult. My ScanSnapHome (SSH) Settings are as follows:

  • Please check to see if yours are the same; the save to path is typically SSH’s folder (in my image the line is “/ScanSnap Home folder”) and must not be DT’s inbox.

  • Assuming those settings are identical, can you check to see if the scans you have made are in that folder? Can you please also post a copy of the settings you have in DT/Preferences/OCR

  • Do you have any smart rules or scripts which might be activating when you scan a document? (I once had a smart rule which was too broad and moved certain documents out of the inbox unexpectedly…)

  • Does the “Adding document” window persist, or does it “appear” to finish but just no visibly add the document?

  • Presumably you have tried restarting your Mac?

  • I’m using Catalina - but FWIW I had to provide SSH with full disk access too - and I see that you haven’t; perhaps that is not necessary with Mojave, but it might be worth a try (security hygiene would suggest you retract that permission if it is actually not required in the end)

I followed your kind instructions and (miraculously?) the system components decided to work together, and they continue to work in harmony. Thanks to all of you for your concern and your help.

1 Like