Using imprint functionality with a sequential counter for multiple documents

Hi there,

in the last couple of hours I tried to create an imprint which prints a sequential number to every first page of all selected documents (e.g. attachments).

The nearest solution to my requirement I got to work like this:

  1. Create an imprint which prints a text („Attachment No.“)
  2. Create an imprint which prints the tags
  3. Create a combined imprint which has no. 1 and no. 2 in it
  4. tag all documents with the desired sequential number (for instance „B 1“, „B 2“ and so on)
  5. use the combined imprint

This works ok-ish for a small number of documents, but not at all for:

  1. a bunch of selected documents (there only the random document of all selected ones got imprinted) and
  2. I have more than only a few documents to tag because tagging becomes cumbersum really fast

Ideally I think the counter function could be a solution but I did not get it to work.

Any tip would be appreciated. Thanks in advance

This should be possible, just tried this. A screenshot of your imprinter configuration might be useful. In addition, how did you exactly imprint the selection? Via smart rules, batch processing or Tools > Imprint?

I made 3 screenshots with (1) Imprint rule with text only, (2) imprint rule with sequential number and (3) combined imprint which I want to apply:


The application of imprints should work like:

  1. selecting the documents
  2. use smart (right-click) menu -> imprint OR Tools -> imprint

If it will be easier to use smart rules I will not stand in its way … :slight_smile:

Are the documents images or PDF files?

They are all PDFs.

I have tried the same settings here and it worked on the selected PDFs. I will continue to investigate the issue.

What sizes are the PDFs you’re processign and how many at once?

I tried with a stack of 12; sizes are mixed from 86 kB up to 4.5 MB

I’ve tested a little bit further:

  • Using smart rules or batch processing makes no difference - no counting imprint.
  • All selected items get the imprint “00000” (or “0” when using index imprint).
  • Previewing the settings show imprint “00001” (or “1” when using index imprint).
  • This behavior occurs on a second Mac too (both have Mohave 10.14.6 and DTP3 3.0.4).

If this is could be a bug please give advice for a convenient bug report format.

Development is already aware of the issue. Thanks!

If this helps dev dept.:
imprint on jpg files works as expected: an increasing number (index as well as counter) with the set formatting appears.

So only PDF with / without OCR do not get the correct imprint.

Thanks for the follow-up.

Update for DTP 3.5: imprint Images still work as expected but index and counter both produce „0“ resp. „00000“ as result for all marked PDF files.

I can confirm this.

Also, when imprinting multiple images, I’m getting one that copies but doesn’t imprint.

I can confirm this too. Tiff files are not stamped either. Other Images are.

I will add a fix for the next update

Followup update for DTP 3.7 - This issue still persists for me as it has in previous versions.

@aedwards : Did you found the bug (?) and is there a fix to be expected (sooner or later)? The workaround of converting the (first page) PDF to jpg, imprint and convert back to PDF is tedious.

Thanks in advance

Just tested with v3.7.2 on Big Sur and I am not seeing any issue here with either tiff images or counters, all worked as expected. Which version of macOS are you running?

I use 2 separate Macs: “Old” Intel iMac with macOS 10.14 and a new M1 Macbook Air with BigSur 11.3.1

None of the 2 described problems is gone. PDF files are imprinted with index/numbers all 0 (zero) and tiff files are not imprinted at all.

DTP v3.7.2 on both machines.

On a side note…

The current version of macOS Big Sur is 11.4. You should stay current with the operating system point releases.