Using JSTOR plugin

My queries abound, it would seem.

I’m trying to use the JSTOR plugin, but I have university access, so I would need to use a proxy. I tried to create my own JSTOR plugin using the proxy link provided by my librarian: I’ve also gone ahead and authenticated using that URL in the DEVONagent browser before attempting the search. The plugin I created does not allow me to enter my user name and password. When I try to do a JSTOR search using either the built-in plugin or the one I created I get 0 results.

The forums weren’t very helpful in trouble shooting this and seemed pretty dated. Is there a step by step process for setting this up via a proxy as described above? Thanks!!

DEVONagent doesn’t support proxies yet. How did you create your plugin actually, did you have a look at the source of the existing plugin?

I just tried to use a proxy URL as described in some of the older forums. There seems to be discussion of proxies in the forums, so can you explain if there is no support for proxies or just not in the way I’ve described? Am I simply not able to use JSTOR through DEVONagent and a proxy from my institution?

DEVONagent does not include any built-in or automatic support for proxies. Depending on your proxy it might or might not be possible to write a plugin for it. Hard to tell without the source of your plugin.

Based on what I was able to read on very old forum posts, I just used this URL:

And how did you exactly use it where?

I tried including it on a “New Plugin.” It currently says “Searches on the website <>.” Again, I’m not even sure if this is correct, but perhaps you know of a way to use my university’s proxy to gain access to JSTOR through the search? That would be helpful.

This doesn’t work, the URL doesn’t include a parameter for the search term. It’s probably better to duplicate the existing plugin and to update especially the values of EngineUrland LoginUrl.

Apologies, but I’m not very literate with this kind of stuff. When I duplicate the built-in JSTOR plugin, I am able to only see the following

Where am I supposed to be making these changes you mention?

Via the Edit toolbar item.

Oh, wow, sorry for being dense. Yes, I see it now. I also see the two values you mention. Should I put in the proxy my librarians provided for either or both of those values? Or something else? (Thanks for walking me through this!)

You could prefix the existing values with E.g.;si=_agentOffset_

…would be…;si=_agentOffset_

…afterwards. But no guarantee that this will work or is even possible in your case.