UTI for Shortcuts, Fountain

Tidying up some workflow between DTTG and DT.
Topics: Shortcuts, Fountain file structure, UTIs

Is it possible to use the Shortcut element “Create Item” to create a Fountain file format file in iOS?
I don’t see Fountain file format in the UTI list in the manual.
All the variables I have tried get me either a markdown file that I can’t change to Fountain, even in DT or a text file which has the same problem.

I have a dtTemplate in DevonThink that does this very well.

Have you tried to set the UTI to the official Fountain file format’s UTI?

I don’t know what the Fountain UTI is or where to find it.

Unless you know something more or have a specific file already…

How Does Fountain Work?

Fountain is not an app. It’s not even really a file format. It’s a simple set of straightforward rules for writing a screenplay in plain text. If you opened a text editing app, or even email, and started typing something that looked like a screenplay, chances are, you’re using Fountain.

From: Fountain FAQ

Otherwise the UTI should be the same as a standard Markdown file: net.daringfireball.markdown

I guess my confusion arises from what I am seeing in DevonThink on MacOS where if you create a file (I use a dtTemplate to make a file called title.Fountain) and I get a file with this in the Inspector:
Screen Shot 2021-11-22 at 12.51.45 PM
I’ve messed around (in iOS and MacOS) trying to convert markdown and text files to Fountain and I’ve never figured out how to convert a file to Fountain Screenplay Document so that DevonThink recognizes it as such. In DevonThink I can create a new Fountain doc from a template and that’s great. It opens in Atom and is saved back in DevonThink, all good.
I’m trying to figure out how to do the file creation part in iOS.
Creating a markdown doc with a Fountain name extension in iOS gets a .md extension automatically added that I can see in MacOS but I can’t remove it.

  1. Fountain is a flavor of Markdown and is unsupported in DEVONthink. So even if the file is recognized as text or Markdown, it wont render with Fountain features.
  2. Are you using a bespoke Fountain application on your Mac?

I am using external Fountain editors (Editorial in iOS, Atom in MacOS). I am not expecting to edit the Fountain files in DT or DTTG.

I’m trying to figure out the file type issue. I can see how DT recognizes a .fountain file as Fountain Screenplay Document as in the screenshot above. What I am trying to do is create a file in DTTG on iOS that doesn’t get the .md or .txt added to it automatically.

On iOS, DEVONthink To Go needs a UTI to work with a file. If there is no Fountain editor installed on the device neither iOS nor any app even knows that something like a Fountain file format exists.

So, if you use the correct UTI and some app is installed that defines the correct UTI plus file name extension (a.k.a. “exporting the UTI”), then DEVONthink To Go should pick that up when you create the file. If the UTI is also defined in such a way that it is a sub-type of net.daringfireball.markdown, then everything should just work.