Ver 1.5.7 not working

Here we go again. This release makes my diary unreadable. Most (maybe every) items, when selected, return “Unable to Read Document. An error occurred reading the document”.

Would it be possible for me to get version 1.5.6 (that worked perfectly for me) back?

Of what type are the documents of the diary? And which version of iOS do you use? We tested on iOS 8.3 and 6.x.

This is on an iPad Air 2 using IOS 8.3 (12F69)
All entries in diary are RTFDs. Other document types seem to work fine (limited testing)
I have not synched with my iMac after the 1.5.7 update in fear of damaging my database (iMac on 10.10.4 (14E17e)
I don’t know what causes this one, but there has been a history of ups and downs for me concerning reading RTFD-format, as you can see from previous posts.

Just tried syncing some RTFD documents to DEVONthink to Go 1.5.7 using iOS 8.3. I’m unable to read any of the documents as well.

On both iPhone 6 (iOS 8.3) and iPad Air (iOS 8.3) the great majority of RTF and RTFD documents are returning the same message: Unable to Read Document. An error occured while reading the document.

The majority of my RTF documents have been created using the DEVONThink Sorter.

  • Rich Miller

When fixing the RTF problem that came with iOS 8.3 we accidentally disabled another fix for RTFDs on iOS 7 or later. Every major iOS version handles RTF a bit differently. Apple has approved version 1.5.8 which fixes the RTFD problem too. Please apologize the inconveniences.

Installed 1.5.8 on iPad. Everything working fine again!
Thank you.