VPN Connection

Hi there,

I just set up my own NAS with webdav to sync my DTTG.
I don´t want to share this to the internet and not to open any ports on my router. Instead I’m using a VPN connection and was hoping that DTTG is able to use this connection.

First I try to setup up this kind of “local connection” but I’m just able to connect to my NAS via the “name”.
[] When connecting via IP address I always get “authentication failed”.
] Using this connection url in other apps is working well.
[*] The credentials of course a fine.

I try to connect via local IP because when using VPN the name resulution / routing is not working. Does someone have an idea how to get DTTG running over VPN ?


Does this work on the Mac or do you only use DEVONthink To Go?

Hi Christian,

my primary database is located on my mac and it is setup up to sync via webdav to a syncstore on my NAS.
With DTTG I can successfully access this sync store when I am located in my local LAN. But its not working from outside using VPN. I thought this is not working maybe because of the missing routing / name resolution and so I tried to change the webdav URL to an URL containing the fixed IP address.


Are you able to access the NAS via WebDAV from the outside, e.g. via the Finder?

The NAS itself is unreachable from outside via portforwarding.
But using VPN and other IOS applications I can successfully connect.

Is the URL’s port the same within and outside of your LAN? Does any of your iOS apps use WebDAV too?

Hi Christan,

thanks for your quick response and your effort in helping me. :smiley:

I´m not sure if this question is the right approach.
There is no real “outside” of my LAN. When being connected via VPN I assume that I mostly act like being inside my LAN. So I didn’t spend any thoughts on different ports or port-forwarding.

I’m sorry if the subject of this topic is a little confusing because it describes my final goal but not the first question / problem is see. So lets sort it out.

Authorisation problem

  1. I.e. I use the IOS App File Explorer and created two webdav connection for the same server
    /path” and

Both are working fine from within my lan as well as from outside my lan when using VPN. From outside without VPN of course it is unreachable and this is how it is supposed to be.

  1. In DTTGO:

I can only use “http://mynas:5005/DATA/DevonThink/
Using “” throws “authorisation errors”

First Question: Why do I get authorisation errors when changing the URL from name to IP.

My final goal
In DTTG the URL “http://mynas:5005/DATA/DevonThink/” is only working from within my lan.
From outside via VPN this connection is not working.

I don’t get any authorisation errors but the “spinning wheel” like if the server cannot be found. Just because of this I tried to change to IP.

Sorry for any confusion or if I am totally wrong with my thoughts on this :blush:


Good question because the networking & authorization is actually handled by the Dropbox SDK. Could you please tap the ? button on the home screen of DEVONthink To Go and choose “Send Feedback”? Maybe the logs will include some hints. Thanks!

did you guys solve this issue? Please share what worked to get the VPN working