Webclipped PDF always contains long lines and small font

I am always using the webclipper to store a website as pdf (one page, clutter free). However reading the pdf on my macbook in devonthink is nearly impossible because the font size is too small and foremost, the lines are very long. The only way to read is to zoom in and not only scroll down/up while reading but also scroll from left to right.
This is strange since it does not keep the line breaks from the article.

So I was wondering if there is a way to customize the font size and the format in any way so that I also can read those pdfs on my macbbok?

No, you can’t customize the fonts in a captured PDF.

What is set in DEVONthink’s File > Page Setup?

This is my setup:

This makes it pdfs really hard to read…

You are right–that’s how PDF works. When I have to save to PDF with DEVONthink, i use PDF Pagination. I prefer to save pages in Markdown as subsequent reading so much simpler.

true, markdown is way better but its not clutter free. I always have to remove adds and stuff. But I guess I will try to use markdown

A PDF is always associated with a page size. If you clip to a paginated PDF, you’ll obviously get pages sized as you specified in global preferences (A4 in your case). Now, if you select “unpaginated”, DT will have to choose a sensible page size itself. I just tried it with an arbitrary web document and got this

Bildschirm­foto 2022-12-26 um 12.07.59

with a font noticeably smaller than on the original document. This was with “clutter”. After selecting “clutter-free”, I got the same problem with an even smaller (and different!) font and very long lines.

I can’t, of course, say how DT determines page width for one-page output. But apparently it doesn’t give a dime about your width setting. Why would it, since it must ignore the length setting anyway?

Also, “line breaks” do not really exist in HTML. The browser breaks the line when it has to because the text is too wide for the container. If you make your browser window wider or narrower, the line will break at another point. It seems that “multi-page PDF” respects current browser settings, while “single-page” PDF doesn’t.

You could play around with the single-page stuff combining with clutter-free. From what I saw, the latter option can result in a completely useless PDF because most everything is considered clutter. YMMV.

I use this approach before converting it into PDF because of the same issues (font size and garbage). This approach allows me to fine tune the document before converting it into PDF.

DEVONsave: A shortcut to help you clip websites to DEVONthink To Go quickly and cleanly - Axle

(There are some discussions here about those shortcut).

1 Like

Thank you the shortcut looks really interesting however I can not get it to work.
Devonthink opens and I here a quick sound but nothing happens and I can also find no error message

Please provide a sample URL that produces the PDF you’re describing. Thanks.

The shortcut only works in iOS/iPadOS, not in macSO DT. The second part, the rule to convert the HTML into PDF, is the part that works in DT after being used the Shortcut in iOS/iPadOS.

1 Like

ah ok thanks now it makes sense :slight_smile:

1 Like


Sorry for the late reply. Here is an example:

This is how it (the line breaks) look in my browser:

This is how it looks in the preview:

And this is how it looks in DT:

For me it would be perfect if DT just used the linebreaks from the current page when I snap it

No worries.
In what browser?


The clutter-free is processing the width of the browser window, including the space allowed for the ads.

Narrow the window until the ads aren’t showing…

Then clip it as clutter-free…

The PDF clipping width can be changed in Preferences > Files > Multimedia. By default the width of the current tab/window is used.

1 Like

ahh thats good enough!
Thanks, this really helped.