WebDAV issue with synology NAS

Dear All,

i have used a Synology DS218 for quite a long time and never had an issue with my WebDAV and DT-synching. I now changed to a DS918+ and I set up everything properly and everything should be running as it should.

On saturday I started an inital sync via webdav and it worked out fine. When I tried to access the database with DTTG, it seemed to have an ip-error and the ip was blocked.
After I reset the ip-blocking, I was not able to access via webDAV via DevonThing at all.
Each attempt to sync my database and set up webDAV will be promted with a error conflich (409) (see screenshot attachted).

I do not know, what the problem is. I have restarted the webDAV server, i created new users, I checked the permissions of the drive. I do not know, why this setup does not work.

Does anyone has any ideas? Or might this maybe be an issue of my synology NAS?

Best and thanks for little hints.

Are you able to to mount the WebDAV server in the Finder (via Go > Connect to Server…) and to create folders on your own?

no, I am not able to connect to it. but the external login on my NAS via DynDNS works fine. so it seems there is any issue with the settings of the webdav server?

Most likely. Any WebDAV server that can be successfully mounted & used in the Finder should be also compatible to our sync.

1 Like

I also use a Synology with WEBDAV for syncing. For me it works fine without any problems. The only problem I had, access using HTTPS did not work. But this was no problem for me.
But this is already some years ago. Perhaps it is working now. But it would be an option for you testing HTTP and HTTPS.
Any post your setting from DTOP here, perhaps I can find something in your settings.
On Synology I only enable WEBDAV, created a shared folder only for DTOP sync and configured the access rights. That’s it.


1 Like