WebDav sync creating a conflict on new iPad Pro

I recently purchased a new iPad Pro and am setting up DEVONThink to Go on it. I put in the exact same WebDav parameters on my iPhone and it is creating a conflict on my server. I’m using a Synology NAS to host the files. The MacBook Air and iPhone sync perfectly fine. The new iPad will not. What am I doing wrong?

Have you put the DEVONthink files on the NAS (above suggests you are), or just using it to sync? the later should work whereas the former probably will not unless you have a very fast LAN.

Just using them to sync…this has worked for about 6 months on all three devices. My iPad broke and I’m replacing it and now it won’t sync without a conflict.

The majority of the time, some kind of warning is given to you - and this is documented in several places.

Is there a triangle on the sync icon in DEVONthink To Go’s bottom toolbar? If so, tap it. What is reported?

Ok. Good. I guess best advice as next step is to clear the sync setup and pedantically per the instructions set up again. If still fails give some screen shots of the setup and maybe we can spot.

In the back of my mind I think there is a network setting for iOS that is needed. @bluefrog ?

Not for a non-Bonjour sync.

PS: This is the next step…
Is there a triangle on the sync icon in DEVONthink To Go’s bottom toolbar? If so, tap it. What is reported?

1 Like

This is the error message I received. Every time I adjust the setting to verify they are ok and hit save I receive a messages that also says “Couldn’t download document”. I have no clue what that means.

Thank you both for the help.

You’re welcome.
A 403 means the user is recognized but isn’t allowed to access the resource.

The WebDAV URL is case-sensitive. Did you verify it against the URL on the other devices?

PS: The “Couldn’t download document” may be a phantom message. Ignore it in this case.

I have copied and pasted the URL to ensure the link is the same.

Do you have individual users - one per device or a general user for WebDAV?

I have the same user name and pw for all devices.

Copied and pasted from where?

And what URL did you paste?

Not sure if I should be posting this but here goes: As I understand it the three top input boxes are what matter. I have copied the top URL line and pasted into the iPad version.

Is it possible that the key of the sync store is incorrect. I can imagine that an incorrect key would also return as a 403.

1 Like

Thank you for the help…not sure what changed but when I changed the folder they were all syncing too it all worked.

Which folder?

I switched the default folder from /home/DEVONThink to /DEVONThink. Only thing I can think of is I allowed the syncing to go one at a time and so there should have been no conflicts but it could be something else. I’m just grateful it is working now :slight_smile:

Thank you so much for the quick responses and all the help!

No problem. Glad it’s working now.