Weird Sharing Issue Between Notes and DTTG

Running into a weird issue recently when trying to share from Apple Notes to DTTG.

Flow is to create a new note and scan a receipt as a document. Then choose the share option, select DTTG, and done. Has worked for a while (including the title copying over).

Recently, the “Done” button is greyed out when I try (and the title doesn’t copy over) and I can’t figure out what I’m doing wrong–or if it’s a new bug…

Tried restarting both apps, and the phone.

iPhone 14 Pro
iOS 17.4.1
DTTG 3.8.1

Why are you adding the document in Apple Notes?

PS: I’m at dinner and can’t test anything right now.

When I try to do it directly in DTTG I end up with a badly cropped image–

Notes gives me a PDF that is cleanly cropped and perspective fixed…but certainly not ideal.

Tried to do it with File app, but took me more steps to get the receipt scanned.

Open to other suggestions…

For a couple of reasons I do my phone document scans with QuickScan.(a.k.a. QS)

Not all my scanning goes into DTTG.
QS is fast flexible software, good at perspective/skew and cropping, as well as doing OCR. Another reason I don’t scan in DTTG is I am usually in an open MD note in DTTG even while I am out and about. It’s easier to scan in QuickScan and leave the scans in that app until I have a few minutes to prep them and send them to DTTG. Priority is to capture the paper and bulk file it and hopefully never look at the paper again.

I have a shortcut for receipts scanned into QS and destined for DTTG that allows me to enter total, tax, tips, vendor info that helps build the name in DTTG (vendor_total_yyyymmdd), and also populates the comments field with key:value pairs that I can extract in DT on the desktop and port to custom metadata.

1 Like

I used to have a scanning app I loved–but then they switched to a subscription model and slowly reduced the features in the version I had purchased.

I’ll check out QuickScan.