Wheel spins forever for initial Cloudkit sync


Yesterday, I setup my Cloudkit sync. I got the spinny wheel and so left it overnight.

Today, the screen still shows the spinning wheel - pretty sure this isn’t working. Any ideas?

What is reported in Window > Log?

the log is empty.

Disable syncing on quit or deactivation the quit and relaunch DEVONthink.

Also, don’t enable syncing all your databases. Sync one. When it’s done sync the next; etc. Keep an eye on the Log window for 503 errors.

OK, will let you know.

Why do you think unchecking that box will make the difference and should I be re-enabling it when it is up and running?

how long can I expect a 5GB first-sync to take (my upload speed is ~18Mbps)?

In case of no issues (e.g. not too many automatic retries) and no concurrent network traffic an hour should be sufficient.


Because syncing was already stalled. No need to attempt it again when quitting the app.

1 Like

OK, so the initial sync of the 1st database completed in 20 mins (nothing in the logs) and now no to the 2nd one.

…any ideas why it stalled the first time (is there anything I should be looking out for during “normal” syncing" later on?

It’s impossible to say without logs but why do you have the legacy sync still enabled?

You say, no to the second one. Is the Log window still empty after trying to sync the second?

Simply because I wanted to ensure CloudKit was working first.

The 3 databases I want to sync now seem to be OK so I have switched off and cleaned the old one.


I guess I can also remove the old location now as well.

[edit: added below]

Yes was empty.

1 Like

Glad to hear it and yes, you can remove the legacy location, if desired.

1 Like