Wordservice and doc problems

I have WordService installed but cannot drag .doc files into DT (I do and they appear as a file with no contents).  Likewise, when I export my database and reimport it, none of the original working .doc files are restored properly (all of the .rtf, .rtfd, .pdf files do fine).  Strangely, of course, I’ve obviously been able to import .doc’s in the past, but am having problems now.  

Just to be clear, all my Word files are labelled .doc.  Also, I have iPhoto installed (there was a DT help file that indicated this might be a problem)  I don’t want to uninstall iPhoto however.  Is there another problem I’m missing, or a workaround?

Thanks,
Brian

Install AntiWordService which will convert your Word documents to plain text. In addition, DT doesn’t know anything about Word documents (like all other Cocoa applications using filter services like AntiWordService). Therefore the original documents are not stored in the database, only the text delivered by OS X and the filter services.

Brian:

I just dropped a Word file into DEVONthink to confirm that I’ve got no problem. Worked fine.

I’m running OS X 10.2.6 with the latest versions of DEVONthink, Wordservice, etc.

Don’t know what to suggest except the usual: log out and log back in – if that doesn’t work, run Disk Utility repair permissions, file system maintenance (DiskWarrior, Disk Utility). Good luck.

Of course, workarounds include opening the Word file under Word or another application and saving it in text or RTF, then dropping the new file into DEVONthink.

Regards,
Bill DeVille

Christian:

You are, of course, correct. I should have waited for your response!

AntiWordService  is freeware and is available for download at <http://www.devon-technologies.com/freeware.php>.

Bill DeVille ::slight_smile:

Hi there,

I got the same problem: AntiWord is installed and works fine with TextEdit e.g.
DevonThink shows, that there are e.g. 324 Words in the Word-Document, but does not show the Text. So I loged out and back in, checked the disk…
Finaly I checked the database: 170000 inconsistencies (is that the right translation for Inkonsistenz?;-), and worse, they cannot  be repaired.

Is there anything I can do (deleting and rebuilding tha Database takes about 36 hours on my PB G3 400!)?

Greetings
Sven

36 hours? Hmmm… should be possible to import gigabytes of data on your machine in 36 hours! But I doubt your database is that big :wink: How much FREE memory does your PB have?

First, do you have a backup (either backups created by DT or by you)? If that’s the case, check if the backup is okay. Otherwise you could send us the database (depending on size/content of course) using our FTP server (<ftp://ftp.devon-technologies.com/incoming/>) and we’ll check if the contents are intact and export/reimport them for you.

Hello everybody, hi Christian,

I reinstalled the newest Versions of antiwordservice and DevonThink - now docs are displayed correctly.
I know, why it takes so long to import everything: It’s about 5GB of text, pdf and pics. Unfortunately about 30% of my pdfs don’t work. DevonThink crashes, when I try to import them.
Can I put one of these pdfs on Your ftp- Server, so You can check it?
I think I solved the problem with the inconsitencies: I imported all my mail with the script and then deleted the new mailfolder on my desktop… I thought, with the script the mails will be really imported to the database…

My PB has 640MB Ram and there are about 6GB free space on my HDD.

Finally: Go on, this can become fabulous!

Greetings
Sven

Sure: <ftp://fp.devon-technologies.com/incoming> Or just drop me an email if the PDFs are not that large.

Anyway, please activate the crash reporter (see preferences of “Console” application, after the next crash there’s a log in the folder ~/Library/Logs/CrashReporter available containing useful information to fix the bug) as even problematic files often “just” work here (and that makes bug fixing difficult, sometimes impossible).

Your thought was correct - and therefore this can not be the cause for your problem.