WordService, TextEdit, and hot keys

I LOVE WordService! :smiley: Use it often in TextEdit, commonly to convert all-caps to “initial caps of words”.

I noticed in the read-me that there is a hot key chord (Cmd Shift C) for that, but it doesn’t show in TextEdit. A hot key would be SUPER nice.

I tried editing the plist file and changed the key chord to Cmd k, saved the file, and tried it out … but it still didn’t work. Do I need to restart? or is something else wrong?

On my system TextEdit uses cmd-sift C to show the color picker. I guess that’s why the hotkey is “stolen” from the service and therefor not working.

You can easily re-define hotkeys for any cocoa application via System Preferences>Keyboard & mouse>Shortcuts. In case of the services you need to define them in the “all applications” section.
You can also re-define the color picker shortcut to something else to free it for the service.
BTW: This works for the styles in TextEdits style popup as well (at least in Leopard).
In any case it is important that you enter the menu name exactly as it appears in the menu (if you want to use Service-Shortcuts in applications with different UI-languages you have to define the same shortcut for each language as the service menu language depends on the language of the front application)

Hope this helps.

Redefining the shortcut as Command-K might cause conflicts with other usages of it. Something like Control-K is probably less likely to already be in use, though the Control- prefix is used by some shortcuts in DTech products.

Thanks, friends - got it fixed with the first suggestion from Johannes: I used Keyboard shortcuts in System Preferences to change TextEdit’s Show Colors shortcut to Cmd-Ctrl-c. After that, the WordService shortcut Cmd-Shift-C worked as designed.

Big timesaver for me! Thanks again.