Bonjour not available?

I’m trying to get Bonjour working, but I’m not seeing my Mac when opening DTTG on my iPhone. Here’s my situation:

  • My iPhone and macOS are connected to the same network - tried on different networks.
  • No network isolation, other multicast / mdns systems (Airplay, printer) work fine
  • macOS firewall accepts all incoming connections to DT
  • No filter software like Little Snitch running
  • Airplay from iPhone to macOS works (_airplay._tcp)
  • Changing ports does not matter
  • Running netstat -an shows a process listening on a tcp46 connection (most others are tcp4)
  • When running the app Discovery it shows my Mac timing out when navigating to _devoncloudy._tcp - it can’t resolve the hostname (no multicast response from DT?)

Enabling Bonjour on my iPhone works fine (I can connect to it from my Mac) - but server on my Mac does not work. Any suggestions? Would it be some IPv6 thing? Or something else specific to the setup of my mac?

Good details … I would, as a first step, turn off the firewall on the macOS machine and see if problem clears. Also, check to make sure when Bonjour enabled on the macOS, Bonjour is not enabled on the iPhone. I don’t know about IPv6 as I’ve never used it on the local network.

Thanks. I did indeed try switching of the firewall. No change unforutnately. Bonjour is indeed enabled on macOS, not iOS.

That’s actually not a host name but the type of the Bonjour connections used by the sync. Is another Mac able to see the server?

I don’t have another Mac directly at hand unfortunately, but will try to see if I can find out.

  • Did you try quitting and relaunching both apps?
  • Are you using a specific Bonjour port or letting DEVONthink self-assign one?

Yes, tried quitting and restarting all apps and devices - multiple times.

Port is self-assigned by DT.

Last gasp idea here… are the network settings all the same, e.g. subnet mask, etc.

Tried with IPv4 in case Bonjour likes that better? (I know not if this a good idea or not, but I run iPv4 and all works)

Yes - all IPv4 settings are the same. Not sure how I can switch DT to listen only to IPv4?

Connect the mobile device to the Mac via cable and disable its WiFi. Can you see the Mac after relaunching DEVONthink To Go then?

I don’t either. But for the time being, just turn IPv6 off? Might be red-herring, but …

Weirdly no - the iPhone cannot see the Mac with the cable attached and WiFi disabled. I’ve got no clue what’s happening.

Discovery shows the hostname is not resolving for _devoncloudy._tcp - but it also is not resolving for other services weirdly enough. Multicast routes are set as expect (224.0.0.0). I’m a bit baffled where to look next…


Is iOS’ Settings > Privacy > Local Network > DEVONthink enabled?

Yes

Solved it. For some reason (most likely of my own doing) the option NoMulticastAdvertisements was enabled for mDNSResponder (in /System/Preferences/com.apple.mDNSResponder.plist. Setting that to false and restarting solved the problem: Disable macOS Multicast Advertisement (Bonjour) | MTeam7

1 Like

Thanks for the follow-up.
I was going to ask you to check into mDNSResponder but went to bed sick before I had a chance. :face_with_thermometer:

Nice article too. Thanks for sharing it.

1 Like

Thanks! Get well soon!

2 Likes