Bonjour sync fails

Hi, I sync DEVONthink and DTTG via Bonjour. DEVONthink is the server, i.e. Enable Incoming Connections is enabled (and it’s not enabled in DTTG).

Since some weeks it doesn’t work reliably anymore, sync seems to succeed immediately after restarting both apps, but fails after the first sync (but I’m not sure whether the first sync succeeds as some Smart Rules with trigger “After sync” don’t run automatically anymore).

There’s no error message shown, when I start the sync in DTTG it seems to work for a moment but then shows the cloud symbol with the dot at the top again.

  • Did anyone else experience this?
  • What are the steps to track down Bonjour sync issues?

(I’ve renamed the global inbox to “Admin” some years ago)

DEVONthink 3.9 on macOS 12.6.3 (ARM64E)
DTTG 3.6.4

Sooo … after re-reading a similar thread’s post …

… and deleting some RSS feed items whose name starts with . sync works via USB-C cable.

However when I try to sync via WLAN then DTTG seems to start a sync. After waiting for some time tapping on the cloud symbol reveals this:

After restarting the mac and iPhone sync via WLAN seems to work. Smart Rules with trigger “After sync” also run automatically again.

@cgrunenberg no idea whether that’s possible at all, but I’m now pretty sure that the issue was related to records (RSS feed items) whose name starts with . . I tried to resolve the problem several times during the past weeks (restarted DEVONthink, DTTG, the mac and the iPhone countless times and also tried to sync via USB-C cable) but couldn’t get the global inbox to sync reliably. No way. But after deleting some RSS feed items the sync via USB-C didn’t fail after some hundred records, it did successfully sync some thousand records in one go. Again, no idea whether that could be the root of the problem, but it was the only thing I changed in between.

What feeds start with a dot?

I think those were all items of this forum’s feed.

Post a screencap of that, please.

I deleted them …

The name or the filename of the item? E.g. filenames created by DEVONthink should never begin with a dot and the name doesn’t matter when synchronizing. But as I’ve never seen such a feed, any additional input would be great. In addition, please choose Help > Report Bug while pressing the Alt modifier key and send the result to cgrunenberg - at - - thanks!

Perhaps they’re still in the trash?

1 Like

No, when I delete something I really delete it.

Do you remember the URL of the feed?

Pretty sure it was a discourse forum feed and checking it now there are only two of them:


Thank you! I added both feeds to a test database but no names or filenames begin with a .

Didn’t say those were currenty added records … No, seriously, I now restored the database from 2023-02-17 00:16 via Time Machine (should already have tried that before, sorry Jim!).

Here’s what I might have changed before sync worked again:

I’ll now check restored vs. current database in Beyond to make sure I’m not dreaming this.

Does the filename of these items also begin with a dot? Do any of your smart rules rename items?

I deleted the old database a few minutes ago, but in Beyond Compare no filenames started with a dot.

Yes, but they are not activated. Currently there’s only

  • one that marks as read
  • one that moves to a “Twitter” database
  • one that OCRs iPhone screenshots

None of them (should) have an impact on filenames.

Do you use dots at the beginning on your own? Some of the items are not part of feeds.

No, not intentionally anymore (the group names were intended back then, meanwhile I use an underscore to sort to the top). Also wondered where the non-group record names are coming from, only thing that comes to mind is some AppleScript that probably doesn’t check whether these names are a good idea …

At least for the sync this shouldn’t be an issue and I just successfully synchronized a database using similar names.