Bookends template

Very exciting to download the new beta 8! So far it looks fantastic.

I have Bookends and I’m trying out the new template for Reference from Bookends. I’m not quite sure how this is supposed to work. I have highlighted a reference in Bookends. I’ve also double-clicked in Bookends to bring up the full data entry window for a specific reference. In both cases when I go back to DT and try the Bookends reference template I get this error message:

(I hope this image shows up!)

Can anybody help with why this might not be working? Am I doing something wrong? Bug in the template? Weird bug due to computer x software interaction? Something else? This is a GREAT new template so I’m excited to get it working.

Okay, apparently the image is not showing. I’ll try again with a link: … s-template

This is a bug that wasn’t fixed until this release. I’ll post an updated script here tomorrow.


Thanks for the update on this. At least now I know it’s not me doing something weird. Look forward to the updated script,


I’m also very excited about the new beta version! However, I’m trying out the new template for Sente Reference and having a very similar result as @mitchellm.

I attempted highlighting a reference in Sente. I’ve also tried bringing up the reference as a new tab in Sente. In both cases when I go back to DT and try the Sente reference template I get this error message:

I am using Sente 6.0.22. Is it possible the template will only work with earlier versions of Sente?

Please try the following:
Reference (from Bookends) (55.8 KB)
Does it work now?

Yes, it’s designed for Sente 5. We’re already in contact with Third Street Software and we will soon deliver a new template optimized for Sente 6 and its new abilities!

Also the new script does not not work and DevonThink still gives a similar error message as before.


The new Bookends script does not seem to work. I’ve tried a few different combos, but this is always the error message I get: … h-bookends

It’s similar, but different in detail, from the first error messages I got yesterday.

I hope this is helpful.

Which version of Bookends are you using? Is a Bookends main window Bookend’s front window and a reference is selected?

I am using Bookends 10.6.1.

I have had a reference selected in the Bookends’ open database window.

Hmm, it works here as expected. Can you send me a screen shot of every on screen, especially with the Bookends main window visible? Bookends is complicated to automate so I used some weird work-arounds.

First of all: wow! Great job with the new pb8.
In my case, the Bookends template (also the new version provided in this post), ALMOST work. I mean: Selecting an entry in BE and launching the BE template generates a new record in BE but the fields are incorrect.
Here’s the output:

Title: Schnelle, Kurt
Year: 24/nov/2009 11:28
Back link: Click here to view reference in Bookends

The back link works perfectly but author field is empty (should be “Schnelle, Kurt”), title is not correct and the year field actually shows the modification date of the BE entry.

Anyhow great job!

Oops, obviously I meant in “DT”

Can you, somehow, send me that record from Bookends so that I can import it here into Bookends and try it myself? I am not a regular Bookends user and so I used self-generated demo data which may or may not be real-world compatible :slight_smile:

Please find attached screen shots of BE and DT Pro. (974 KB)

I’ve sent a PM with a link to a BE export: sent you some references just in case you want to see different types of references. By the way: it would be great if the template could import also BE keywords!


Here’s a download link to a Bookends export of about 15 references:

I hope this helps.

I have exactly the same problem of michellm


I’m wondering if there’s any update to the Bookends script issue. I’d really love to use it, but so far nothing seems to work.