Bookmarklet problems--question for Bluefrog

I tried posting a reply to an old post of yours, where a PDFing bookmarklet produces a bookmark, but apparently you didn’t see it. I’m troubleshooting a problem similar to one you solved in the post. You had commented:

If the extension runs into an error it will do this as a fallback.

I’ve tried a lot of different things to try to get the chrome bookmarklet to work as well as it did in v. 2: restart DT, restart Chrome and finally, restart system (I really don’t like doing the latter, as MacOS no longer tracks Spaces like it used to, and resetting every time I restart is tedious.)

No joy. They previously had mostly produced the PDFs I wanted, but stopped doing that reliably. Now, it’s mostly bookmarks. (I can save some sites, like this one, as PDFs.) This is the key to my DT workflow. I need a fix.

Question: What kinds of errors do these scripts run into? What’s different about DT3 or 10.15 that it no longer works reliably to produce PDFs?

Is anything reported in the log window?

Only a whole bunch of “missing files” in the Trash. It seems to me that DT shouldn’t be reporting on the Trash. It did show “bookmark” for a lot of entries, but didn’t disclose why.

Thanks for asking.

The Trash is still a location in the database, so it’s best to empty the Trash routinely if you don’t want such results.

Is there a way for Trash to be excluded from Search?

I’d appreciate any help with my earlier questions. Thanks!

Is there a way for Trash to be excluded from Search?

No, this is not possible. Development would have to assess implementing such a thing.

What kinds of errors do these scripts run into? What’s different about DT3 or 10.15 that it no longer works reliably to produce PDFs?

Development would have to respond on the technicalities. Also, this is incorrect as a blanket statement as many PDFs are successfully made on a variety of sites.

Even if it works on other systems, I’m reporting to you that I’m having this problem on my system. Please make inquiries as to what I can do to regain reliable function of the PDF bookmarklet. Without it, I can’t input data to DT.

Thank you.

There is the option to print to PDF and see if that works.

Are you referring to the Share: Add to DT3 function in Chrome? I was able to get it to work 3/3 PDFs in a trial.

Because I use this function all the time, I really need a one-button bookmark or keystroke combination that places the PDF directly in my Inbox, skipping the sorter. (That’s what I have now.) Could you help me script that?

No. I was referring to printing to PDF via the print dialog.

Also, if you are clipping from a browser into DEVONthink you cannot bypass the Sorter. It is part of the mechanism.

I apologize for being thick, but I’m unclear which Print to PDF command you are referring to. I can print to PDF from Chrome, but that doesn’t place the file in DT. Please explain which function you mean.

Print to PDF and save it to the Inbox alias in the Finder’s sidebar. They will put it into DEVONthink’s Global Inbox.

I apologize for needing so much handholding. I created an alias for my dtbase2 file, but it wouldn’t drop into the sidebar. It showed up somehow in DT as a second database with the same name, and different contents. This got bewildering, as one db had today’s date, and the other had fewer files and a date a month ago.

I found that alarming, so I deleted the alias. Now, only the db with the date of a month ago is left. The total size of the db in the DT3 folder hasn’t changed, happily, but the newer files aren’t displaying. What’s going on here? Do I need to rebuild?

Once we get that back to where it had been, how do I create a sidebar in Finder?

Do you have Time Machine backups available?

Install DEVONthink 3 > Install Add-Ons > Global Inbox in Save Dialogs. If it has already been installed you will see a Inbox alias in the Finder’s sidebar.


I’m testing a new online backup, but can’t get data out of it until the complete backup is done. Bummer… I haven’t been able to enter TimeMachine since I upgraded from Sierra. It saves backups, but I can’t access them.

I believe that all the data is still there, because the total size of the db file hasn’t changed. All I deleted was an alias. Is this a situation where a rebuild could be helpful?

I’m assuming that the alias won’t appear in the Finder sidebar until I reboot. Does that sound right?

No. If you add an alias to the sidebar, it should appear immediately.

Start a support ticket and we can look into this.

Since I didn’t want the Global Inbox in the first place, could you please ask the devs what I first asked for: What kinds of errors do these PDF bookmarklet scripts run into that cause them to default to inputting bookmarks? Thank you.