BUG: Missing values when sending web pages from Safari to DEVONthink

When I send web pages as PDFs to DEVONthink via “Print → send PDF to DEVONthink 3” these errors happen:

sending the page in Safari’s reader mode: the document in DEVONthink has the name “unnamed document” und the document’s URL is not stored in the field “URL”

sending the document in Safari’s normal mode: the document in DEVONthink has the correct name but the URL is not saved with the document

This worked correctly before. I reinstalled my iMac with Sonoma yesterday, maybe a connection to that? But I think it is a general problem, as reported in Devonthink PDF issue in Safari Reader Mode - DEVONthink / Feedback - DEVONtechnologies Community

Sonoma is buggy, as has been noted more than once on the forums. And so far, the release notes for the 14.1 beta release don’t seem to be addressing anything very important so far.

I updated to Sonoma about a week ago (don’t ask me why. Now I know I should have waited …). Afterwards I had huge problems with TimeMachine and iCloud-Drive synching. About 6 hours of calls with Apple second level support did not help. Tried a lot of things and finally erased the machine, reinstalled MacOS and put back apps, data and config from TimeMachine. Did not help either but after sending iCloud drive to hell (maybe it belongs there?) I’m finally able again to work with my Mac again. Terrible week it was but at least I learned a lot about MacOS during that time. Next time for sure I will wait and not beta-test the released OS.

Ugh! Sorry to hear it was that bad an experience!

yeah, really bad. Sometime in between I thought about returning to Windows, but as DEVONthink was my reason to convert to Mac it’s the reason I’ll stay there :wink:

1 Like

By the way, the title and URL will be preserved in Sonoma in the next maintenance release.

1 Like

Great news, thank you!

Which can either mean that they didn’t do anything about it or that they did but don’t mention it in the release notes. Both seem equally probably to me :wink:

This has been the first time in a long series of macOS updates that I did NOT “upgrade” immediately, and I was/am looking forward to messing with some of the new features. But it was this forum that stopped me from doing so this time around, as I have no desire to deal with crippled DT3 functionality for anything that was added to Sonoma.


Version 3.9.4 is now available and works around these issues.

1 Like

installing 3.9.4 did not immediately fix the problem described in this thread. I tested by sending a PDF of a few web pages to DEVONthink and still the documents had no title and URL. Finally I recognised that as soon as I clicked on “send PDF to DEVONthink” DEVONthink activated and a dialog popped up for a very short moment and vanished at once with no chance to click on its buttons. Its text was something like “DEVONthink needs the right to access …”. Luckily the “ok” button on the dialog was default and finally I was able to press Enter on my keyboard as soon that dialog appeared. Afterwards the problem was gone. Any chance to make that dialog actually wait for mouse or keyboard action?

EDIT: I guess it was this setting that was needed: