Cannot capture clutter-free web archives

I just upgraded to DEVONthink to Go 3 and am unable to capture clutter-free web archives. Every time I try, the share extension simply creates a 0-byte bookmark, instead. Is this a known issue and, if so, is there any way to work around it?

Thanks!

I do not remember seeing this problem mentioned before. Does it happen with all URLs or only some of them? In the latter case, it might be helpful to post URL(s) where it does not work.

This seems to happen with all URLs. Here are a few examples:

Every resulting database entry looks like this:

When I click Download (0 bytes), I am shown an error message stating that DEVONthink to Go “couldn’t download document”:

Strangely enough, these items all sync to my Mac as non-zero-byte Web internet locations, but not as clutter-free web archives. Any idea what may be causing this?

Very strange, I agree. I tried same with the first URL to Daring Fireball, and from Safari on iPhone I “shared” to DEVONthink ToGo 3.0.6 on IOS 14.4.2 three ways: Bookmark, Web Archive, and Web Archive (clutter-free). And all three worked fine, and then immediately and successfully synced across to my desktop DEVONthink (via Bonjour).

Setting? Corruption? Struggling with a useful thought!

I can confirm @rmschne’s observation (tried only the first of your URLs): clutter free webarchive works fine for me (Safari, iOS 14.5, DTTG 3.0.6.
Just a stupid question: Did you reboot your device after upgrading DTTG? The share menu is known to behave erratically after an app upgrade/update…

Thanks for checking! :bowing_man:t2:

That’s actually a really good question! I couldn’t remember, so I just tried rebooting my device (an iPhone 12 mini) and unfortunately the issue is still preventing me from capturing clutter-free webarchives with DEVONthink to Go 3.0.6 on iOS 14.4.2.

Any other ideas?

Does it work if you’re not using clutter-free?

Yes, as far as I can tell I am able to capture ordinary web archives just fine.

Update: I just tried to capture a web archive of the following URL via the share extension, and when I went to open DEVONthink to Go it crashed.

Reopening the app, I found that it had captured a bookmark (a.k.a. a “web internet location”) rather than a web archive. This appears to be 100% reproducible for me. Can anyone else reproduce this, as well?

Clutter-free or not?

PS: I’m not seeing an issue with an internal build here so this may be addressed for the next release. (I know we have some web capture code changes in it.)

Not clutter-free for that particular URL.

Oh, interesting—any idea when that release will be?

We don’t announce development timeframes but we are testing internal betas at this time. Thanks for your patience and understanding.

Understood. Be that as it may, why would I be unable to capture clutter-free web archives even though other folks on this forum seem to have no trouble doing so?

I just updated to iOS 14.5.1 and I still can’t capture clutter-free web archives. Is there any way to get this working again?

I just tried your stir fry URL and worked fine here–Web Archive and Clutter Free Archive. My hunch (as you are presenting no evidence for me to think deeper) is there is something corrupted on your iphone for the installation of DEVONthink ToGo. Could be hardware? Corrupted install? Have you tried removing DEVONthink ToGo and its data and re-installing (so maybe it gets installed in some other portion the machine, masking the issue).

I’m running IOS 14.4.2 and you report 14.5.1. I’m on DEVONthink ToGo 3.0.6.

I actually ran into this issue with a fresh install of DEVONthink to Go 3, so presumably this isn’t the result of data corruption? I’d prefer not to completely uninstall and reinstall the app again unless it was absolutely necessary.

Ok. Your choice. However, I don’t think that yet proven, and since it started just after the “fresh” install I’d say it’s not yet ruled out.

Do I know for sure? No. Do I know that doing another “fresh” install will for sure help? No.

Would I, if in a similar situation, do a fresh install? Yes. Can’t hurt.

(I’ve seen mysterious crashes with other IOS apps over the years fixed with this brute force technique. Apple gives us few options on IOS devices to debug, as you no doubt have noticed.)

What do you think, @BLUEFROG? Would you recommend deleting DEVONthink to Go and all its data from my phone and then re-installing it to try and restore the ability to capture clutter-free web archives? Or is there a slightly less destructive option available?

Hard to say at this time, though a reinstall certainly has the potential to fix the issue or be ruled out as the solution.

A fresh install on a different iOS device?