Cannot delete some files orphaned by DEVONthink To Go

I have a number of files and folders on my iPad and iPhone (different on both devices) that appear in the’s Recently Deleted group that cannot be deleted. My only option when long pressing on the items is Info, and when I get info they all display as a DEVONthink To Go Recently Deleted item. The trash is empty in DEVONthink To Go on all devices, sync appears to be functioning fine, and I have tried rebooting the devices. Would appreciate suggestions here as having files I cannot delete means I cannot do a Select All to delete all the other files in Recently Deleted.

1 Like

Are you commonly accessing DEVONthink To Go items through the

Not on my iPhone, sometimes on iPad. I don’t think any of these documents and folders were accessed with, as they were all test or temporarily items that I would have no reason to access outside of DEVONthink. I suspect they are items that were deleted in DEVONthink and somehow were caught in limbo on the device.

I just deleted DEVONthink To Go on my iPhone and the orphaned files were deleted from

I wonder if there is some caching we need to change. @eboehnisch is the expert in those matters.

The is caching extremely. So even when a file is deleted in DEVONthink To Go and it tells the so, it could happen that it doesn’t clean its cache. Usually that should adjust itself after a device reboot or just time.

1 Like

It’s still not clearing out here. I have orphaned files in Recently Deleted going back to December, all from DEVONthink To Go. I’ve had multiple restarts, iPadOS updates since then and no change. Am I the only one seeing this? Frankly, in my opinion this is a serious security concern as deleted data once protected by DEVONthink To Go’s Security feature is stuck in limbo in with no security measures at all. The only way I see to delete the documents is to delete DEVONthink To Go.

1 Like

Do you see these files in DEVONthink To Go, too, or are they rightfully gone there? When an item is deleted we send the deletion request to the Files app which, it seems, properly moves the file to the Recently Deleted section.

Does this happen for other apps, too, so is it a Files problem or an issue with the information we send to the Files mechanism?

Once deleted and emptied from the trash in DEVONthink To Go, they don’t appear in DEVONthink To Go. The only documents and folders that are stuck in Recently Deleted are from DEVONthink To Go.

I don’t know if it’s important, but it has nothing to do with sync. I had deleted DEVONthink To Go from my iPhone to clear these orphaned documents and have not yet synced it again. The problem is still there. As it is now, the delete process is completely broken for me. What I am describing happens with every deleted document and every deleted group, on iPhone and iPad. It’s not a random anomaly at all.

As a side note, I know there are pros and cons to having deleted documents moved to the Trash/Bin on macOS or to Recently Deleted, but I question if this should even be a thing on password-protected databases, but that’s a different discussion.

These “deleted” documents, are they actually accessible? Because the original file is long gone by then.

If the document had a thumbnail, then yes that is still visible. You can see that in the image I posted above, I can see that the last document in the list is a plain text file with 3 lines of text.

But tapping it doesn’t do anything I hope? I’ll check if we can remove items completely, at least if a passcode is set for the app.

I can now see some of the same behavior in iOS 13.3.1.
A bug has been filed on GitHub with screencaps of mine.

No, tapping it doesn’t do anything with the document, but the full preview of the first page is visible, and readable, in the thumbnail that shows in the Info pane.

Interesting. I wonder how Apple wants this to work. We’ll investigate. Thanks for bringing it up!

1 Like

Has this problem been resolved, or is there any news to report?

I also experience files being stuck in the “Recently deleted” folder. As explained by @Greg_Jones, the only option is the (i) button and retrieve information. No way to actually delete them from the “Recently deleted” folder.

I agree with @Greg_Jones this might hold a certain security risk to some, although the file itself seems to be inaccesible.

Edit: this appears to be device specific. I have files stuck on one device, which arent’t visible on another.

Nothing to report at this time.

Yes, the data is kept by the as the file itself is long gone. We’ll need to explicitly tell Files to remove that “ghost” too.

Checking in yet another time. I’m still seeing old (and seemingly random) filenames in the recently deleted folder in Files.

I can confirm this seems to be device specific, yet it’s strange to see filenames of files I’ve deleted months ago.

I know DT doesn’t disclose release dates of updates, but is there any possibility the repair of this bug can be expedited might you have any influence on it? Or is this up to Apple to resolve?

There is a security risk (data loss) involved I think, though it is limited obviously if the actual file is indeed deleted and the filenames are simply some buffer of the Files app. Still it’s undesired behavior in my opinion.

The security risk is not limited if the documents are small, plain text files, as is not uncommon for me as I take a lot of plain text notes that are no longer than a page. The entire text of said documents is viewable in the document thumbnail, even though the document itself cannot be opened. I just captured this image today.