Cannot enable Apple Mail plugin: "Incompatible Plugin"

I’ve used the Apple Mail plugin with DT since the very beginning of my DT journey.

A few weeks ago the plugin stopped working, after resetting my Macs PRAM, so I’ve deleted the plugin, and am trying to re-install it without luck.

Everything I do, ends in the error message “Incompatible Plug-Ins Disabled / Mail has disabled the following plug-ins: DEVONthink_BigSur.mailbundle”

Here’s what I’ve tried so far:

  1. Quit DEVONthink + delete the plugin in Finder, from folder ~/Library/Mail/Bundles
  2. Reboot my MacBook
  3. Re-Install the plugin from DEVONthink and enable the plugin from Mail settings (I choose “Allow” during plugin activation).
  4. Ensure that all “DEVONthink” permissions are enabled in System Settings > Privacy: Location, Calendar, Contacts, Reminders, Camera, Microphone, Accessibility, Full-Disk Access, Files and Folders, Screen recording, Automation – all DEVONthink entries are enabled
  5. Reboot again, just to be sure
  6. Start Mail → ERROR

No matter what I do, I cannot get the plugin to work.

I have enabled error console to log warnings during mail startup, and I found the following entries that are related to the plugin:

System Policy: Mail(3034) deny(1) file-read-metadata /Users/philipp/Library/Application Support/Mail/Plug-ins/Bundles/Users/philipp/Library/Mail/Bundles/DEVONthink_BigSur.mailbundle

Plugin compatibility check failed for DEVONthink_BigSur.mailbundle. The plugin's Info.plist must have a Supported12.1PluginCompatibilityUUIDs key whose value is an array of strings that contains the compatibility UUIDs for the supported versions of Mail. The compatibility UUID value is found in the PluginCompatibilityUUID key of Mail's Info.plist

...

bundleRecordWithBundleIdentifier failed for com.apple.syncdefaultsd: Error Domain=NSOSStatusErrorDomain Code=-10814 "kLSApplicationNotFoundErr: E.g. no application claims the file" UserInfo={_LSFunction=+[LSBundleRecord bundleRecordWithBundleIdentifier:allowPlaceholder:error:], _LSLine=150, NSUnderlyingError=0x7f83270ba210 {Error Domain=NSOSStatusErrorDomain Code=-10814 "Unable to find this application extension record in the Launch Services database." UserInfo={NSDebugDescription=Unable to find this application extension record in the Launch Services database., _LSLine=645, _LSFunction=_LSPluginFindWithInfo}}}

-[TCCDAccessIdentity initWithMessage:]: self.bundle=0x0, bundle:(null); for: com.apple.syncdefaultsd with url: (null)

Judging from the error message, the problem is caused by some missing or incorrect values in a .plist file, but I’m not very familiar with those files. I’m not even certain, which .plist file is causing the problem. Do you have any suggestions on what could resolve the issue?

1 Like

I would

  • close Mail
  • close DT
  • delete the bundle from the path quoted in the log in your post (/Users/philipp/Library/Application Support/Mail/Plug-ins/Bundles/Users/philipp/Library/Mail/Bundles/DEVONthink_BigSur.mailbundle)
  • delete the bundle from /Users/philipp/Library/Mail/Bundles
  • Reboot
  • Open DT and reinstall the plugin, observing which plugin version is being offered (it should be 4.0.5)
  • Open Mail
  • Activate the plugin in Mail
  • Come back here and say thank you or that was no good

My assumption is that for some reason the bundle in that mad long path is not being overwritten when you reinstall, thus my suggestion you remove it manually.

2 Likes

Have you looked in DT to see if you can import emails from there in the email window? I’m asking because I’m getting an error message, but it is actually still working if I import an email within DT, so I ignored it :grimacing:

DEVONthink is indeed able to import messages & mailboxes without the plug-in from Mail but it’s a lot slower.

Which version of macOS and of DEVONthink do you use? What’s the version of the installed plug-in?

I experience the same problem like @philippstr.

Advice by @Blanc doesn’t help. I don’t see any DEVONthink_BigSur.mailbundle in Library/Mail/Bundles. There is only one file Properties.plist.

Any additional advice? Thanks a lot! It would be really great to get the Apple Mail plugin running again. I used to use it a lot.

About my setup: macOS 12.1 (including Apple Mail 15) and DEVONthink 3.8 which offers Mail Plugin 4.0.5.

Is there a bundle in the path quoted in point 3 of my list above?

No.

If I follow Application Support/Mail/Plug-ins/Bundles/Library instead of /Bundles I find GPGMailLoader_6.mailbundle. But following /Bundles/Users/USERNAME/Library/Mail/Bundles/ leads only to Properties.plist.

Checked for hidden files and folders as well.

Did you check /Library/Mail/Bundles (on the startup disk) or ~/Library/Mail/Bundles (in your user directory)? Does DEVONthink 3 have full disk access?

DEVONthink 3 has full disk access.

Now I checked both (startup disk + user directory). But the folder on the startup disk only shows GPGMailLoader_6.mailbundle. No DEVONthink bundle.

So that would suggest the bundle is currently not even installed.

Does DEVONthink offer the option of installing plug-in version 4.0.5?

Yes, installation is offered.

But the attempt to install the plug-in 4.0.5 leads to the failure notice which @philippstr posted in the beginning of this thread.

I just checked version 4.0.5 successfully on Monterey 12.1. Do you already use a beta of version 12.2?

Hi @Blanc

Thanks for your feedback. I’ve tried this (deleted both bundles) and reinstalled after reboot, but still get the same error…

However, I did not see any version number when installing the plugin. Where is the version supposed to show up?

Just as an fyi… I am having the same issue. Using Monterey 12.1 and Apple Mail 15.0. Nothin I have done works…

M1 or Intel Mac? And could you please select Mail.app in the Finder, choose Show Package Contents in the contextual menu and send the file Contents > Info.plist from the package to cgrunenberg - at - devon-technologies.com? Thanks!

  • MacOS Monterey 12.1 with Apple Mail 15.0 / Intel MacBook
  • DEVONthink 3.8
  • I cannot see a version number of the plug-in (and also, it’s the only Mail plug-in I’m using)

Update:

I found that the folder /Users/philipp/Library/Application Support/Mail/Plug-ins/Bundles/Users/philipp/ had a wrong owner. This was the problem, apparently. Here’s how I fixed the problem:

  1. Quit Mail
  2. Rename (or delete) the folder /Users/MYUSER/Library/Application Support/Mail/Plug-ins/Bundles/Users/MYUSER/
  3. Delete the file /Users/MYUSER/Library/Mail/Bundles/DEVONthink_BigSur.mailbundle
  4. Open Mail and check the settings to ensure the plugin is really deleted
  5. In DEVONthink: Open the “Install additional modules” menu item and uncheck all items and click “Install” (not sure if needed)
  6. Quit DEVONthink
  7. Quit Mail
  8. Start DEVONthink, and install the Mail Plugin.
  9. Start Mail, go to Settings and enable the plugin. Grant all permissions.
  10. Here, I’ve checked if the folder from step 2 above was re-created again with correct permissions
  11. Now I’ve hit the “Apply and restart Mail” button to enable the plugin

→ It’s working for me now.

Intel. File just sent…

Thank you! Version 4.0.5 of the plug-in should be indeed compatible. Please check the owner of the folder mentioned by @philippstr - is it the right one?

That explains why the plugin wasn’t being overwritten; out of interest: did you try deleting the mailbundle from there, or did you discover (and solve) the ownership problem beforehand?

Step 5 of your instructions probably isn’t required.