Cannot share PDFs from Safari to DTTG anymore

I noticed this already some time ago, but thought it would get fixed anyways with some update.

When trying to share a PDF that is open in a Safari tab on iPad and selecting DTTG as target, the whole screens dims down a little bit and then comes back - without having done anything or offering the DTTG share menu!

When doing the same for a regular URL, it works as expected - but not for PDFs!
It also does not work, when selecting “PDF” for a regular webside from the Share options …

Any idea?

As showing is better than telling or writing:

1 Like

Ah, and I already tried to disable any Safari Extensions and also enabled and disabled the Apple Safari Content Blocker … behavior stays the same!

fwiw A workaround I use is sharing to the Global Inbox via the Files app

After saving this as file to the Files App, it can be shared to DTTG - to any database, not just the Global Inbox.

But sharing PDFs from Safari directly to DTTG did work before!

No idea if DTTG has a problem, or if iPadOS resp. Safari has a problem.
But I did not notice other Apps sharing PDFs to having this problem…

What version of iOS and DEVONthink To Go Are you running?

Latest 15.x: 15.7.2
Always latest DTTG

The current version of Apple’s mobile OS is 16.3.1.
Are you refraining from updating due to hardware limitations?

FYI older iPhones (like my iphone 7) maxes out at 15.x apparently.

15.x is still a main supported version!

As parts of my devices cannot update, and all of my devices are older and 16.x brings performance problems for older devices, I will not update to anything beyond 15.x

Sharing a PDF from Safari to an App seems to be basic OS functionality and not brand-new rocket science, or?

It should work with any version of iOS / iPadOS where DTTG is capable of running ;.)

Does that mean, that this is broken on 15.x and below, but works for 16.x?

I would assume that this mechanism has not changed for numerous versions of iOS / iPadOS … and that it should work on any and all versions.

I tested this now on 3 devices, but all at and the behavior is the same.

But sharing such an PDF to other Apps like OneDrive, Telegram, Notability or just Mail does work flawlessly!

So it is a problem of DTTG!

iPhone 7 with iOS 15.7.3 (maxed out version, far as I know, for this device) with DEVONthink ToGO 3.6.4, with a PDF files sourced from the Internet into Safari, sharing to DEVONthink ToGO seems to NOT work for me.

I wonder, if it works for 16.x and what changed that such a basic feature would fail.
But I have no 16.x device to test this.


15.7.3 is available for iPhone 7, and iPhone 6s (mine, but sharing PDFs does not work too)

But it is not available for iPad Pro 9.7 or iPad Pro 12.9 second generation, both are stuck at 15.7.2 but could be upgraded to 16.x …but I heard bad things about performance on those older devices.
I would rather not upgrade them to 16.x

We don’t control sharing and there are issues with other apps sharing as well. Try running Shortcuts via the Share menu and very often things are blurred out, entries missing, etc. And these shortcuts have absolutely nothing to do with DEVONthink To Go.

Well, at some point old stuff in the Apple ecosystem will break.

I find it useful to learn what is indeed broken to help guide me to when it is time to move on to new stuff.

But with sharing PDFs from Safari (either genuine PDFs or the URL shared as PDF from the options menu) only DTTG seems to have this problem!

And also only in such a way, with shortly dimming the whole screen …

Today, I got an PDF by email and tried to share it (from Apple Mail App) to DTTG on iPad - this resulted in the same situation, a short dimming of the screen and no success.
I needed to save to Files App first and share from there.
Very strange :slight_smile:

  1. I just emailed a PDF to another account of mine.
  2. Received it in Apple’s mobile Mail app.
  3. Long-press > Share on the attachment.
  4. Chose DEVONthink and the database.
  5. Imported as expected.

And yes, bear in mind I am on iOS 16.3.1.

Anyone else running the old OS able to confirm or deny?

Very interesting - thanks for your test!

I just repeated this with the first mail I found that contains an PDF - and it also worked perfectly fine!

But then, I remembered that I experienced this with my salary PDF, which I did not send as plain attachment, but as encrypted ZIP file!

So, I searched this mail, touched the attachment, entered the password and then touched “Preview content” which opens the PDF.
And from this view, I used the share button in the upper right corner and THEN, the same happens as with Safari!

Sorry, I should have given directly more details …

But maybe this can give some hint about the reason for this behavior?

No worries.
You’re doing something out of the ordinary in this instance. You are the only person I’ve ever seen trying to do what you’re doing.

How are you zipping the file?

It is uncommon to open an encrypted zip file from mail?

I only know people who do this often or regularily…

Anyways, I encrypted and zipped with 7zip on Windows, but tested this with an unencrypted ZIP file created on iPad from the DTTG PDF manual too, which I compressed to ZIP with the Files App and send it to myself by Mail App.

Opening the attached ZIP file behaves the same:

If you just open the ZIP and then share the included PDF, everything works normally!
But if you open the PDF to watch it and then try to share it, the same bug reappears: The screen get’s dimmed shortly and you cannot share the file!

I mean, here we have a workaround - just share from the opened ZIP file within the Mail App, not while watching the PDF.

I only mentioned this, as it shows the same behavior like Safari when sharing any variant of PDF file!
That may give a hint about what component exactly is buggy …