can't create a Clip from DEVONthink forums?

First of all, I’m a newbie, so if I’m just doing something massively stupid here, forgive me!

Since I’m just starting to learn DEVONthink, I created a DEVONthink Help folder for myself in my Personal database, and I tried to use the Firefox extension to Clip a forum post on adding tags to multiple selections, but when I view it in DEVONthink, it looks like

The is one of the more hilarious software problems I’ve ever encountered, if it’s not just me doing something dumb…

P.S. Saving as a WebArchive and as a PDF produced the same result.

I find it easier to open the DT forum from a bookmark in DT itself. When I want to save a thread that I’d like to archive, I click the Print View icon in the forum, then, in the contextual menu, choose “Capture PDF” or “Capture Web Archive”. The Print View is a nice presentation of a thread and makes for a good archival reference copy. Better, IMO, than a clipping from the browser.

On any forum page, the Print View icon is the leftmost of these three icons:

Thanks so much! I used your method to capture a Web Archive of this very post…which is so meta my brain is about to explode.