Chrome Browser Extension: How to clip a complete pdf?

Hello, I have a very simple question.

Given that I’ve opened a pdf document in my browser window and want to use the extension to file it into a folder of my DT database. How can I achieve that? When I use one of the pdf options, I only get an empty pdf in the DB. When I use the webarchive or html options, it’s also not the pdf proper that is included into my database, but a webpage including the pdf, so that Adobe Reader will be opened within the DT browser…

Could it be possible that you’ve simply forgot to provide a method for this most simple task…???

What’s the URL of the PDF?

Well, I had this problem on several occasions. The last one was this: … ulz.hh.pdf

Are you able to clip this PDF successfully using Safari & the “PDF (Paginated)” or “PDF (One Page)” format? If this should fail, which version of DEVONthink and of Mac OS X do you use?

I clipped this in Chrome on 10.8.5 in DTPO as a Paginated PDF, however the name that was given the file is: 4 1 ,3 $. : :question:

The actual text content of this PDF document is basically garbage. E.g. convert it to plain text or open it with, select all, copy the selection and paste it into a TextEdit document and you’ll see. That’s why the automatic name is not that useful.

Sorry, but it’s not only that document, as I said. It’s all PDFs and all browsers (Chrome, Firefox and Safari).

I just tried this one: … nalism.pdf

This time - as you wished - with the Safari Add-On. Again the “paginated pdf” option leads to one empty page of pdf in the DT database.

My versions:
Safari: 8.0.6 (10600.6.3)
DevonThink 2.8.6
MacOS 10.10.3 (on a MacBook Pro Mid 2012)

So, Mr. Grunenberg, there is no ‘official’ response to my question? Is this just a ‘quirk’ of my individual configuration?

I had hoped for something better… :frowning:

Personally, I never clip PDFs that were downloaded and displayed by the browser. I just save them to Downloads and import to DEVONthink. The DEVONthink clipper (eg clip to PDF) is intended for converting HTML to PDF, but not for converting PDF to PDF. I.e, it is not “Clip a PDF” but “Clip to PDF”. Since there is no HTML content in a PDF displayed in the browser, you get garbage.

The examples given by the poster above work just fine if the PDF item is saved and imported as I mention.

Same here, although I use Safari’s ‘Export as PDF…’ and select DEVONthink’s Global Inbox as the destination.

However, I tried using the clipper on the Journalism PDF linked above, and used PDF (paginated) as the output and the PDF looks fine in DEVONthink-don’t know why the OP is getting blank PDFs.

Well, of course I do the same - because there is no other way. It would be much more convenient to have a unified interface for importing any content from the browser.

The wonderful Evernote Clipper shows how this can be done. Unfortunately Evernote doesn’t allow for a sufficiently nested folder structure, that’s the most important reason why I still prefer to work with DevonThink.

But I guess if the DT people don’t keep up with the current developments, their days may be counted soon, at least at this workplace here. (Evernote DOES allow for nested tags, btw.)

Did you miss the part where I said this?

Perhaps there is something else creating a conflict on your system, as it works fine here with the example PDF URL that you posted above.

Try disabling all the other extensions except for Clip To DEVONthink and see if the problem persists.

Umm… people do have vacation time as well as very pressing development issues.

What current developments are we not keeping pace with, especially when other apps are attempting to catch up with us (and we are certainly not standing still?

Okay, I have to apologize for my impatience. Will do as advised, and maybe report later.

Oh, btw, I HAD done that experiment already, at least if you mean de-activating all other BROWSER extensions for excluding possible conflicts: As I am usually not using Safari, the Devon Think extension was the only Safari extension at work. Still, the problem persisted.

Now I have de-activated some DT Modules, especially the PDF Services, and the Apple Mail Extensions. This seems to have solved the issue…!

Nope, zu früh gefreut. That was only a partial success. With this document: … k_2015.pdf

I have the same problem again. After importing it with the DT Clipper as “paginated pdf”, the result in the DT database is another 4kb empty one-page pdf. :frowning:

This linked PDF also works fine here, and as a FYI, I am using DEVONthink Pro Office with none of the DT Services and extensions disabled. I’ve linked a video below where I imported the PDF linked above via the DEVONthink’s Safari extension Clip to DEVONthink 1.2.2.

link to video

I use this forum’s prosilver forum style (set in the user control panel), so my screen capture of the forum may look very different from the one you are accustomed to using.

Thanks, Greg. After watching your screencast I tried it again from my desk at home and everything went fine, with Safari as well as with Chrome.

At the public library, alas, where I’m working normally, the problems persist. So can it be that the extension is using some special protocols or ports that may be blocked there…?

Anyway, I will now stop pursuing the issue. Thank you all for your efforts.

PS: I liked hearing the birds in the background. :slight_smile:

Note to future forum readers: it’s always helpful to explain the context for problems – usually a bit more than “x doesn’t work. Why?”

For example “x doesn’t work when I’m flagpole sitting and my USB drive containing my journal database is stolen by a curmudgeonly stork. Why?”

Wow, I didn’t realize the screen video was also recording the mic! Yes, I’m very blessed with all the winged visitors that are outside my home office.

As to your question re: the library as the source of the problem, I would say that is a real possibility. You might want to ask someone at the library if they are blocking some connections, perhaps also check the Console the next time you are there and this happens.