Clarification on using smart rule / "on import"-trigger

Hi all,

I just want to have some confirmation, that I understand smart rules correctly.

  1. Currently, I linked the DT3-“global Inbox”-folder in the finder’s favorites and put documents there, and they appear in DT3 “global inbox”. So far so good, but no smart rule is triggered here for “On import”. The rules match, as there is a number indicating how many documents match the criteria, and when I apply the rule manually, it is executed as expected, so the only problem is that the action is not triggered automatically

  2. Now I created a normal folder in the finder, and in DT3, I create a “file and folder indexed”. Now, if I change some existing rule to scan this new “indexed folder”, and add the action “Execute script - external - move into database” as a first step, then the rule is executed “on import”, as soon as I put a file in this folder via a external file operation.

So, using the inbox to import documents seems to be not the correct way, rather use a external folder, which ins “DT indexed”, right?

Thank you very much for your support

Screenshots of your smart rules would be helpful, I think.

Here is one rule as an example…

![Bildschirmfoto 2020-08-19 um 05.44.52|690x335](upload://oM


I think @BLUEFROG might be able to answer that. Did you try using “on create” instead of “on import”?

Just out of curiosity: What do you do with .eml files? AFAIK, those are in a proprietary Microsoft mail attachment format which is not usable anywhere but on windows.

Yes, I tried every “trigger” which is available. But The rule always work if started “manually”…

<What do you do with .eml files?>
;-)). If I use the script for transferring mails from AppleMail to DT3, the resulting “document/file name” of the mails in DT3 ends with “.eml”…

The Global Inbox’s alias in the Finder sidebar should work with the On Import event trigger. I just verified it’s working here.

Do you have any other smart rules targeting the Global Inbox that come before this smart rule?

No, there is no other rule intercepting the one… I have many rules, but different “criteria”… all rules indicate a number of matching documents, but no action is performed… unless I choose “Apply rule” manually, then everything works…

Just to be quite sure, please move one of the rules which should trigger (e.g. the one you posted) to the top of the list of rules and then perform an appropriate import; in addition, add a second trigger “on creation” to the rule.

What I’m looking for is to be quite sure you haven’t got a prior rule which is triggering inappropriately and then cancelling further actions.

In addition: if you don’t use ”the script” (which script?) to import the mails, but instead mark a mail in Mail and then send to DT using the command in the context menu (that is assuming you have the plugin installed), does it work then?

And can I ask you to clarify:

Does that mean none of your rules ever trigger automatically?

I tried the other triggers before, but did it again, nothing changed. And yes, NONE auf the rules ever ever triggered automatically… as said before, the criteria works, because there is a number at the right side indicating, how many documents match the criteria. And if I use “apply rule”, it works, too.

In addition, I could say, that I try already different ways of importing to DevonThink. Either way through the menu in AppleMail for an opened mail “E-Mail / Zu DevonTHINK 3 hinzufügen”… or through the DT-script "Add message(s) & attachment(s) to DevonThink…

I read other messages here in the forum and I had the impression, that importing to the DT Global-Inbox will never trigger such events, because there was mainly the advice to set a “hourly”-trigger.

I can’t confirm that, I have a whole bunch of smart rules which are triggered in exactly that way. Can you try something though, please? Either put the term in ‘Inhalt stimmt überein mit’ in inverted commas (Anführungszeichen, double quotes) or use a simpler term, say with just one word, and then see if your rule triggers automatically (I know they trigger manually, but I seem to remember something similar I stumbled across a while back)

I don’t seem to have the script you are referring to - can you point me to where you are selecting it from?

I have edited this post a number of times now - I probably shouldn’t be doing this in the middle of the night. But listen up: I’ve just played with a smart rule, was able to see the same problem you had, put my content search term in “” and the rule then worked.

This rule works for me; it also works with “Kind is E-Mail” instead of *filename ends with .eml
The same rule does not trigger automatically (but works manually) if vielen Dank für Ihre Bestellung is not enclosed in ".

@BLUEFROG: may I point out this bug (?) to you, please?

Ohhh, come on ;-))… When putting the term in inverted commas, the rule is triggered correctly…

Thank you so much!!! I will check for the other rules, if this could be a similar problem there…

Excellent :slight_smile: this is not consistent - I have found that sometimes if the term is in inverted commas, it won’t work (although then it doesn’t work manually, either). Pls let me know how you get on :slight_smile:

Ok, I just checked all of my rules, and they all have the “content contains …” part in it, without the inverted commas in common. So fixing this and now, it works… great!!! Again, Thank you very much!!!

1 Like

Out of curiosity: do all the search strings contain umlauts?

No, but all have some sort of “not normal character” like:
“AN: 1234567890” (the colon)

And the space… It would be interesting to see, when the quotes are required and when they aren’t.

vielen Dank für Ihre Bestellung

This is a phrase and should be quoted in a search.

Yes, no, maybe - but why will the rule not trigger automatically when the term is not quoted, but still display the document and act on it correctly when triggered manually?

And why, for example, does Meldung zur Zusatzversorgung work without quotes, but “Meßwerte am Notfallort” didn’t work when not quoted? Is @chrillek onto something when he suggests that special characters may have something to do with it? Going through my smart rules, it turns out that I have quoted terms which contain

  • more than one word AND
  • (punctuation OR
  • special characters)

Those terms which don’t fulfil those criteria are not quoted, and work perfectly.

This is the first question we’ve had on this so I have no data at this point.

Story of my life :wink: