clip to devonthink extension

after updating safari to Version 10.0.2 I get a popup "Do you want to allow this page to open “DEVONthink Pro Office” when clipping a website to dtpo. This was not the case before the update, it is annoying to click ‘ok’ each time as I do this often. I couldn’t figure out how to turn it off. Has anyone experienced this and knows how to turn it off?
Many thanks,

YES (experiencing it) :imp: and NO (able to turn it Off yet) :imp:

Another terrible update in the Sierra debacle.

Note: Chrome and Firefox nicely ask, “Hey, do you want to remember the choice to use DEVONthink? Okay, cool! I’ll remember that!” and works as expected.

I have the same problem. Might be time to switch my browser.

This is so incredibly annoying. Is it somehow built into Sierra? What’s the rationale?

Read the thread. It’s a bug. Bugs have no “rationale”.

Thanks. Did read thread before posting. Wasn’t clear it wasn’t a “feature.”

It’s actually hard to distinguish bugs & features of macOS these days :mrgreen:

I’m experiencing this same issue on El Capitan after doing an update to Safari. So it looks like it might not be limited to a Sierra problem.

It’s on Yosemite too…
I think it is part of Safari v 10.0.1 (10602.

I started noticing when I updated Safari…

I’m also thinking it’s a a Safari issue. Definitely not a problem with Chrome or Firefox (as Jim said). I’m a Safari user. Suppose I could try rolling back a version.

It IS a Safari issue.… sigh…

I’m not sure what the benefits of using the DT clip extension are. I get the same behaviour on El Capitan but… I don’t get that behaviour using the share menu in the toolbar of Safari. Any reason to use the safari extension instead of the share menu extension?

Invoking the clipper using Safari’s share sheet is fine, if it works for you. It’s two clicks instead of one click – which bothers some readers 8)

(Here is a KeyboardMaestro macro that will find and click “Add to DEVONthink” on an app’s share sheet – invoked with [size=150]⇧^- [/size] Modify it as you wish.)

Oh, my. You continue to be my automation Santa Claus. Thank you!

As a further complication on my system, if I answer that I do want to “allow” the page to open DTP, I’m taken to a Take Note window where, at minimum, I have to click Save. Does anyone else have this problem?

I do not. Takes me straight to DTP window.

I think it’s a safari issue too. It doesn’t happen in other browsers, correct?

Firefox and Chrome allow you to remember the choice that an extension is safe to use. Safari does not. :imp:

I have another problem with the extension in Opera:

the window “do you you want to launch xxxx” pops up, but i don’t have the time to say ok, it disappears at once.

What could i do?

I don’t find the preferences file that i could edit manually in order to allow this “forever”.

Any idea?

Would not like to miss DTPO-Extension, it is so important.

I found a workaround by myself, don’t know if its ok, but seems working:

/Users/admin/Library/Application Support/com.operasoftware.Opera/Extensions/pjoafdokmbmkpolhcnmnkgaicbajigcc/1.2.6_0.activate.js

// Needs to be a function due to Chrome’s security policy for extensions
function reloadPage()

(function ()
if (navigator.appVersion.indexOf(“Mac”) >= 0)
var url =
+ encodeURIComponent(document.title)
+ ‘&location=’
+ encodeURIComponent(window.location)
+ ‘&referrer=’
+ encodeURIComponent(document.referrer)
+ ‘&width=’
+ window.innerWidth
+ ‘&text=’
+ encodeURIComponent(getSelection())
+ ‘&source=’
+ encodeURIComponent(document.documentElement.outerHTML)
+ ‘&encoding=’
+ document.characterSet;

	window.document.location = url;
	[u]setTimeout(reloadPage, 1000);[/u] => changed to 10000
	alert ("The Clip to DEVONthink extension only works on a Mac. Sorry :slight_smile:");


Now i hav the time to click OK “allow forever”