Cloudme.com: Internal Server Error 500 on iOS, MacOS, iPadOS, but not with MacOS Finder

I have no issue with Dropbox – never had. Perhaps try with one of your users and see.

Good to know. I’ll give it a try again.

I had the same Dropbox problem, switched to CloudMe, and then reconnected to my Dropbox account when CloudMe was down longer than usual (and hard to contact). The original sync problem w/ Dropbox seems to have gone away.

I should post the rest of this in the DTTG forum, but will mention here as it’s somewhat related… Now every time I open DTTG on my iPhone, Dropbox opens and asks me if I “allow” access. This never used to happen when I synced to Dropbox for many years. And it doesn’t happen on my iPad, so I guess it must be some permission setting that was inadvertently changed on my iPhone. I’ll poke around, but any suggestions would be appreciated! - Jim

Do you have more than one Dropbox account?

Nope, just the one.

  • What operating system are you running?

  • Does the behavior recur after rebooting the device?

Thanks Jim. I think it’s fixed now. There was a link from the error message to Dropbox (how to manage 3rd party apps). So I disconnected DevonThink from Dropbox, then “allowed” it when asked again. After rebooting all the devices, it looks like it’s working again.

Excellent! Thanks for the follow-up and I’m glad to hear it’s behaving now. :slight_smile:

Bummer, looks like I spoke too soon. All my devices continue to ask me to log into Dropbox now. Says it’s an API Request Authorization. I looked in Dropbox support docs, but they say to check with the 3rd party app support. I guess I could set up a new sync store on Dropbox – and delete the old one – but I have many databases on 4 devices, so I’d rather not have to take all that time. But otherwise, not sure what else to try at this point.

Do this…

  1. Quit DEVONthink.
  2. Go to this URL: https://www.dropbox.com/account/connected_apps
  3. Click DEVONthink Sync and press the Disconnect button.
  4. Relaunch DEVONthink.
  5. Click on the sync location in DEVONthink’s Preferences > Sync. It should open the authentication screen.
  6. Allow access and let the machine switch back to DEVONthink.
  7. Quit and relaunch DEVONthink and see if the behavior recurs.

This seemed to work for a while, but by the end of the day one of the devices (iPhone) started asking again for permission to connect to Dropbox and then gradually so did the other devices.

Thanks for the suggestion though… - Jim

FYI, we’re continuing the discussion of Dropbox asking for permission every time over on this thread