"Command-C" copies the path to the document rather than the highlighted text

I’m running into two issues, and I imagine they are related.

  1. Command-V repeatedly pastes the same thing, a file path, even after having copied other text (using Command-C). I noticed this when I tried to copy the first line of an rtf using “Command-C” and paste it into the “Name” line in the inspector using “Command-V”. Rather than pasting the text, it pastes the path to the file on my Mac (not the item link). This is not the case when I use “copy” on the dropdown menu instead of the “Command-C” shortcut.

  2. When I try to highlight and then copy text using “Command-C” from a DT webarchive document and then use “Command-V” to paste it into an email, it pastes the file path to the document on my Mac rather than the text I highlighted. However, again, when I highlight the same text and click on “copy” from the drop down menu, rather than using the “Command-C” shortcut, and then paste into my email with the “Command-V” shortcut, it pastes the text, as expected.

Are there Copy/Paste preferences somewhere that I am not aware of? It seems that when I attempt to use “Command-C” to copy highlighted text from a document in DT, it pastes the path to the document on my Mac rather than the text itself.

I’ve been googling and haven’t seen a solution. I’m sure this is obvious. I just haven’t figured it out.

Any suggestions?

Command-P is the Print command, not the Paste command.
Have you modified your shortcuts?

1 Like

Whoops! I mistyped. I meant to type “Command-V”. I’ll edit the post.

Everything looks to be in default settings under System Preferences/Keyboard/Shortcuts/App Shortcuts. Is there a way to change shortcuts within DT itself?

No worries and no you can’t modify shortcuts in DEVONthink except for a small handful, e.g., for the Sorter.

Does this behavior persist after rebooting the Mac?

Yes. I rebooted it, and then installed the latest Monterey update (Version 12.2).
It is a 2020 M1 MacBook Air, 16GB Memory, 1TB HD. Still have 500GB of free space. Same problem. When I use Command-C and then Command-V, the file path is pasted rather than the highlighted text.

This only happens within DevonThink. I tried it for plain text, rtf, formatted note, markdown, even OCR’d pdfs. Same result. There has got to be something simple somewhere I’m missing.

I copied text in a web archive and pasted it into a draft email in Apple Mail. No issue there.

What email application are you using? They’re definitely not all created equally.

A screenshot showing the window right before using Cmd-C (and especially the active selection) would be useful, thanks.

Sure. And just to reiterate. The same thing happens whether the document is rtf, plain text, markdown, formatted notes, or even a pdf where I highlighted a section, etc.

This may have something to do with it. I noticed that in the dropdown menu there is no shortcut listed to the right of the copy command. Is this normal?

I use the native Mac Mail app.

Have you modified shortcut keys in the Keyboard system preferences or via some other application?

1 Like

Honestly, I’m not certain. I don’t think so. That’s what I’m trying to figure out. Did I accidentally modify a shortcut somehow, somewhere, without realizing it?

So here’s a thought experiment to come at this from the other direction. @BLUEFROG or @cgrunenberg . If you wanted to erase the Cmd-C shortcut for copy in DT, causing the shortcut to disappear in the dropdown menu, and create a shortcut usind Cmd-C that only copied the File Path of documents in DT, regardless of which text you highlighted, how would you go about doing that? Are there different ways to accomplish this result?

Is it possible that I unintentionally did this at some point?

I’m at the point where I’d be willing to completely reinstall DT (while preserving my current databases of course). My fear is that the issue would persist even after all that.

I’m open to you’re recommendations.

The only possibility to copy the path is actually via the Path pop-up menu of the Info inspector. But as the name of the menu item is identical to Edit > Copy, I’m not even sure if it’s possible to assign a shortcut via system preferences.

@cgrunenberg @BLUEFROG

Just saw this in the inspector dropdown menu next to the filepath. The Cmd-C to Copy shortcut is listed there… to copy the file path.

On the one had this makes sense (to copy). But on the other hand, is it possible that somehow Cmd-C now ONLY applies to copying the file path (within DT), rather than what is highlighted?

The shortcut is now indeed bound to this menu item & feature. But no idea how you actually did this. Did you check System Preferences > Keyboard > Shortcuts > Apps?

@cgrunenberg Yup. I’ve been scrolling through the other items on the left as well. Must have been an unintentionally genius move on my part when I was working late and tired :wink: