Connection to server timed out

I use DTPro with To Go my iPhones and iPad and synced to my Macbook. Not updated Mac OS to Catalina but otherwise everything is up to date.

I receive a constant Connection to server timed out. I left my home with my iPad to be attached to my iMac with a Lightning cable to sync, and spent like 8 hours outside. When I returned home I had the error message like 60 times - like this
|19:24:44: mobile@ipad-80.local|Connection to server timed out.|
|19:31:09: mobile@ipad-80.local|Connection to server timed out.|
|19:38:08: mobile@ipad-80.local|Connection to server timed out.|

I do not think that when the two devices are connected with a direct cable I need t restart my router or my computer as I thought that the sync connects the two devices quite directly.

This error message came out many times in the last 2-3 weeks and I had never such a problem when I sync my iMac with my Macbook.

Have no idea what to do but it is very time-consuming and a sync should be working perfectly.

Did you enable incoming Bonjour connections on both devices? This is usually not necessary and not recommended and cause such issues. It’s sufficient to enable them on the Mac and to add a Bonjour sync location on iOS.

Bonjour was on for my iMac but off for my iPad. I witched off Bonjour on my iMac and now my local network offline meaning no sync…

Are the databases on the iPad up-to-date? A timeout is not necessarily a real issue as the next sync will resume the previous one.

I guess they are not as I divided my previous database into two small ones, had the same problems and I deleted one of the databases from my iPad and then I tried to sync the new database. You wrote that a timeout is not an issue but it stops the procedure, takes time to continue and to me it is just an endless headache to check what is done and still after weeks of trying I do not know where I stand. How would I know whether the sync has been properly done and finished?

An additional sync attempt should be quite fast if everything has been already synchronized.

I attempted to have a sync but again it stopped every five minutes with the error message. So in essence I am unable to verify if the sync is perfect or not… What are my other choices as where I stand with syncing of course not really acceptable

I would appreciate a suggestion of what should I do and I really hope that it is not to sync my iPad fully again…

Hold the Option key and choose Help > Report bug to start a support ticket.

I understand what you mean by “real issue” here, but expecting something to synchronize only to have to manually baby-sit repeated attempts to ensure I actually have current data on all devices is, to me, a very real issue.

More frustrating is having to watch the macOS Log window, because the iOS progress spinner cheerfully lies to me, as if data’s still transferring, even after DEVONthink Pro’s Log window indicates “Connection to server timed out”. Which, by the way, typically happens within a minute or so of each attempt to migrate data between my iPad, MacBook, and iPhone.

Actually, it’s not clear which device is telling me something reliable: after DEVONthink Pro’s Log window declares “Connection to server timed out”, the iOS sync spinner graphic continues from database to database, and time-out messages keep getting logged on the Mac.

It’s completely unclear to me what you’re doing. This is like telling you didn’t get from A to B to retrieve a package from a warehouse, but didn’t mention whether you were sailing, driving a heavy truck or flying by jet. DT and DTTG offer various options to synchronize.

Could you elaborate:

  • are other devices involved beside a macOS machine and an iOS device?
  • is synchronization performed directly, over a LAN or over the internet?
  • if applicable: what are your LAN connection speeds?
  • what protocol do you use to synchronize your data?

I did fail to mention many of those things, it’s true. They’re also not relevant. While they might be directly related to the underlying issue(s), none of them are at the root of the problem I’m describing: DTTG failing to accurately inform me of the state of things. It says it’s timed out, yet it continues to sync. Maybe. Or does it? The tiny progress circle fills too slowly to provide any sense of “how much longer?” if there’s any amount of data being moved, the iOS spinner only tells me something’s happening (but not what’s or how much longer it might take)and seems to disagree with what the macOS log windows says.

1 Like

Sync resumes on its own on an interval.
Also, in DEVONthink To Go, you can long press the sync icon to see sync activity. Have you tried that?

Hi! This whole long-press thing is an issue, too. It’s undiscoverable (not the best UI design) and, following rules I haven’t yet internalized, does different things at different times and/or in different contexts. Sometimes it does nothing; there’s no visual feedback on iOS, though, so maybe I’m not hitting the button cleanly (though my hand-eye coordination doesn’t seem off in other contexts). Other times it shows a spinner. Still other times it shows a file-count. The times it does nothing disproportionately discourage me from trying it. Weird but true (we users are the worst).

I’m looking forward to DEVONthink To Go 3.0. :slight_smile:

Can anyone explain where the sync icon that you long-press is? Is it the cloud thing at the bottom of the side panel? If it is log-pressing does nothing when I try.

Yes, it is the cloud icon in the bottom toolbar.

This sounds like a useful tip, but nothing happens when I long press the cloud icon?
Version 2.7.8 (16484) on iOS14.3
Thanks

Probably in line with Apples current UI guidelines (if any such thing still exists), cf. the horrible things they did to discoverability on i*OS :frowning:: Clicking on a text that looks nothing like a button, long or force clicking somewhere to get details (widgets et al), down sliding to update (except, of course, in Safari, where you have to tap on a graphic element that doesn’t indicate it’s tappable).

1 Like

What I have found to be useful:

  • For a speedy initial sync, I have to unplug all my networks on both devices, connect my iPad with the lightning cable, and let bonjour sync it. I definitely need to restart DTG at least once so that the network stack picks up that there is a new faster network. I have never been able to do this with either my Mac or iPad connected to any other network.

  • For incremental syncs, on Mac (running the bonjour server), set the Preferences > Sync > Synchronization to Manual.

For the latter point, my suspicion is that if the request to sync is triggered on both sides (e.g. if you have it on automatic and/or a time interval on Mac, and you just made an edit on the iPad), these can clash in the handshaking stage or something. Without a solid debug report, I cannot say.

I love your product, but honestly guys, there is a problem here. I’ve tried this in many many different scenarios, last of which I made a WIFI AP (System Preferences > Sharing > Internet Sharing) on my Mac running DT3 and synced DTG to it. It is NOT that it doesn’t work, it is that it is basically hit or miss, even in this best of scenarios.

Plus, In DTG, in order to make sure the files are synced I have to do a pull-down gesture to trigger a sync. But this should not be the case. Synching should be auto-triggered after each file edit. This is the mentality that the cloud has fixed in us. I expect my DT files to be immediately available to me when I’m in my local network, passing from one device to another.

2 Likes

Works intermittently on iPad Pro and iPhone, never on iPad Air.