Custom page width when saving as PDF with Sorter?

Hey there,
When I want to save a web page in DT with the sorter, I use PDF (one-page).

This work well, however the produced PDFs are visually hard to read: I find the font to be too small for the line length (some lines are up to 200 chars / 35 words — I’d prefer to have 20 words max in a single line).

See how your blog post is easy to read online — font size is ok, you made sure to limit the width of the column, it’s a pretty good experience:

However, once captured, it’s a lot harder to read. Look at how each sentence is almost 50% longer — resulting in a smaller font:

From what I understand, the way DT captures a page is to “render” it in a virtual window and then capture the PDF.
I think that reducing the width of the capture window would solve my issue: because there’s less word on a single line, document will look a bit more zoomed-in, and font will look bigger.

Is there any way to reduce the width of the captured PDFs?
Or even better, to customize it, so that I can adapt depending on the kind of content I’m capturing? (Keep it does that pretty well — sorry, no screenshot)


There’s no such public option yet but I’ll forward this.

Hi, any progress on this I may have missed?

I’ve noticed a lot of articles I’ve saved for later annotation are very difficult to read on screen when I go back to review them. To the poster’s original point, they are often 50 % wider pixel-wise in PDF form than the original web page. If you view the PDF such that you can see all of a single line of text, then the text text is tiny. Either way, the number of words per line is 25% to 50% longer than the original view. Much harder to read and consume the text in the wider format once saved into DT as PDF.

How did you exactly clip the web page? By using a browser extension? Or opening the Sorter’s Clip to DEVONthink tab and selecting the desired browser?

I typically use the browser extension while browsing in Safari on macOS.

Do you capture paginated PDFs or single-page PDFs?

I still have the same issue. I’m mostly using single page PDF, using the extension for Firefox.

I’m now using to capture single page PDF which are far more readable. Apart the fact it’s another tool / step, it’s a lot better.

Could you please send a PDF created by DEVONthink (single-page, clutter-free disabled) and one by Paparazzi to cgrunenberg - at - plus the URL? Thanks in advance!

@cgrunenberg Sure, I just sent you an email with a few example PDFs.
Let me know how else I can help.

I typically do single page if at all possible. Pagination is a big impediment to highlighting text and referencing text when the paragraph breaks on a page. When single page doesn’t work well, or some other problem surfaces, I try to use Safari Reader mode and print to PDF in DT3.

Hi. I had a moment to look this over a bit more. When I print and save to DevonThink in my browser, I typically get PDFs that are 8.5 to 11 inches wide. When I clip to DevonThink either in my browser or otherwise, I get PDFs in the range of 14 to 20 inches wide in the sample I checked. Basically it’s as if the clipper is saving pages at 2x size of what they’d be if printed. If I look at the clipped files, clipper also appears to reflow the text rather at a smaller size (maybe the browser default text size in the rendering tool?) rather than maintaining the font size to width ratio. When the smaller text reflows to fit the wider page size it becomes unreadable.

I bet if the page size were either constrained to 8.5 to 11 inches, or the font size scaled with the width of the page, it might address the readability issues. You could try halving whatever the clipper is doing to calculate width, or scaling the font size 2x to address the reflow issues.


Is there a fix or workaround for this issue? I’m seeing the same problem, on the Mac, iPhone, and iPad. Tiny fonts!

I’m now using Paparazzi!, export to pdf and import into Dt. Works perfectly on 95% of websites.

Interesting. I’m messing around with using Mercury Reader (on Brave) or reader mode (Safari), then printing as a PDF to DevonThink. It’s a few extra steps but it results in a nice, readable PDF. I would prefer a native Devonthink solution!

Which “same problem” exactly? By the way, there’s a setting in Preferences > Files > Multimedia to specify the width for single-page PDFs.


Same problem = tiny fonts, possibly due to excessive page width.

I’ll try that single-page PDF setting. Thanks!

Is the document actually zoomed to the original size? The fonts shouldn’t be changed at all.

Yes, fonts are too small when zoomed to original size, and columns too wide when zooming document.

Is that “PDF clipping width”? The options are “Automatic” and “points,” which seems hairy to fiddle with. Is there are recommended setting if “Automatic” results in fonts that are too small when clipping articles?

Yes, that is the correct setting.

What site are you clipping from that yields small fonts?