Database problem?

I run DTTG only on my iPhone 7 and 2017 iPad. I’m having issues with my databases not syncing correctly through iCloud. I went through my DTTG a few days and sent it to iCloud to be the same. I tried to syncing it up to my iPhone to show the same as well. It hasn’t been working so I would like to delete my iCloud data and start over with my databases. How do I do that?


Assuming the Mac has the master database(s), you could do this…

  1. Delete DTTG, reinstall it, but do not set up the sync location yet.
  2. On the Mac, go into System Preferences > iCloud and click the Manage button. Select DEVONthink To Go then click the Delete documents and data button.
  3. In DEVONthink’s Preferences > Sync, right-click the iCloud sync location and choose Clean Location. This will clear out any sync data. You can now add, modify, or remove an encryption key for the sync location , but it must be done before you sync a database.
  4. After the clean is done, check the checkboxes next to the databases, in the Databases pane on the right, to sync to the location again.
  5. After a successful sync on the Mac, set up the iCloud location in DTTG, using the same encryption key, if you specified one.
  6. Then touch the sync location and import the database(s).

Remember: DTSync is done locally, then iCloud uploads to Apple’s servers, then to devices using your Apple ID. This means databases may not be immediately available to sync on the other devices. The initial sync requires patience, as we have no control over the speed and reliability of iCloud’s process.

Also bear in mind, DTTG should be in the foreground and the mobile device awake for the initial sync. The Background App Refresh option is controlled entirely by iOS and only allows approximately a 30 second window, when it allows it to happen. This means we can’t control if, when, or how long it happens. Subsequent syncs are faster since there’s less data being transferred.​

I don’t have a Mac, just iOS.

Please select Help > Contact Us in DEVONthink To Go to start a Support Ticket.

Had sync issues, invalid encryption key, followed your April 19 instructions, now its working again, very great full sir.

Welcome @Gerard

You’re welcome :slight_smile:

Note: For an invalid encryption key, it’s often easier to solve the issue than the method above but I’m glad it worked for you.

For some strange reason I cannot clean the sync location.

CleanShot 2022-03-08 at 10.19.14

I suggest that you open a new thread for your problem and provide more detail (sync method etc) there

That’s the case if the location is currently busy (e.g. performing or preparing a sync). Disable the automatic/scheduled sync, restart the app and then it should be definitely enabled.