Devonthink web clipping saving as bookmark instead of PDF

I’m running into the same issue now. I was just using this URL with the Chrome extension: It saved it as a web link, not as a PDF. Repeating things in exactly the same way 2 minutes later resulted in it saving as a PDF correctly. Upon restarting the app (attempt number 3), it also worked correctly. This has been a recurring problem for me, and I don’t feel like I can trust the extension to clip things reliably. Do you have any suggestions?

MacOS Ventura 13.3.1
DEVONthink3 v3.9
Chrome v112.0.5615.137

Welcome @jtbeales

As has been discussed many times on the forums, a bookmark is created as a fallback if clipping should run into an issue. So there is no bug here.

And as evidenced by your second clipping attempt, it is likely a network error or slow responses from the remote server.

PS: Due to the ever-changing technologies employed by web designers as well as the vagaries of networks, not all pages can be successfully clipped. There is no “clipping standard”. These things are developed independently and with their own solutions. Though our extension works in many instances, we have it on our list to enhance in the future. Thanks for your patience and understanding.

@BLUEFROG Thank you for your quick reply! I’m sure it’s a nightmare to try implement solutions to things like this.

In the meantime, would it be possible to have the extension notify you if it was successful in clipping a PDF? That way users could know if they needed to import it manually. Thank you!

Also, apologies if this is already implemented somehow and I’ve just missed it. DT3 has so many features that I still haven’t learned them all yet!

While it doesn’t show the type, clippings are shown in the Notification center if you’ve allowed DEVONthink to show notifications in System Settings > Notifications.

I was the OP in this one so just wanted to say thank you, as always, for your incredibly committed responses to queries from technologically challenged DT3 users like me!!

Have a good day.

Around 80% of the time I try to use the Clip to Devonthink Firefox extension with Format = PDF (one page), it will instead save as a web location. When I repeat the action in exactly the same way, it saves as a PDF.

This happens across many domains. The only other extension that could interfere would be uBlock Origin. I admit I have too many tabs open (~200 oh god), but browsing performance is still great.

I’m on Devonthink 3.9.4, Firefox 121.0, macOS 13.6.3. I’ve experienced this bug for at least 6 months.

Of course attempts to reproduce this bug fail. When I make a new tab, go to a random site and try, it succeeds.

I see above that saving as a web location is a fallback. Is there a way to get a debug log indicating the cause of the error with saving as PDF? Maybe timeouts need to be increased?

Then what point you to the conclusion it’s a DEVONthink issue?

I’m not sure where the communication breakdown is. When I am going about my day, saving websites as I so choose, around 80% of the time it saves as web location despite “PDF (one page)” being selected. Each time when I retry, it correctly saves as PDF. I’ve done this hundreds of times.

I’m clicking the button in Devonthink to save as PDF and it’s not doing it or providing me an error, therefore it’s a Devonthink issue. Did you have another theory?

It is certainly hard to reproduce! That’s why I was hoping for a debug log.

When’s the last time you rebooted the Mac?
Or your router?

Current uptime on my mac is 13 days. Router lost power a few days ago. As I said I’ve dealt with this issue for at least 6 months, but I’ve held off reporting because I can never reproduce it.

Screen recording of it happening:

Admittedly the first saving took awhile, like it was timing out. I think it usually happens faster.

This problem has been affecting my usage of DEVONthink for over a year now.
It has been said that it’s because of network issues, but I don’t see how this can be an explanation.

I have a fast connection and this has happened hundreds of times, always with a consistent pattern, as @cyounkins described: the 1st time it saves as a bookmark, and only the 2nd time it saves as PDF.

But even if the cause could sometimes be network speed, I’m curious as to why it has been decided to implement a fallback that consists of saving a bookmark instead.
Why not a retry mechanism that honors the user request of saving as a PDF? It’s preferable to take a few extra seconds to finish the task but at least saving in the format that the user wants.

Could this issue be looked into, please?

I continue to experience this as well.

@luisneto Which browser are you using?

I’m curious as to why it has been decided to implement a fallback that consists of saving a bookmark instead.

Because a bookmark is a lightweight capture and still useful.

@cyounkins : I am using Safari.


Please don’t get me wrong, but I see that only a specific sentence of my comment was addressed, as if it was the only thing I had written. It gives me the impression everything else that I wrote was disregarded. :slightly_frowning_face:
Please note that I don’t have an expectation of getting immediate replies here. It’s preferable to wait but seeing the comment lead to a constructive and productive conversation.

I think that the fallback to a bookmark would be appropriate there wasn’t something better that DEVONthink could do.
And as I said, I believe a retry strategy is more appropriate than saving in a format that the user doesn’t want. The downside of that is probably just a few extra seconds.

The current behaviour is analogous to ordering a meal at a restaurant, and when the chef is preparing a dish, he/she uses the wrong ingredient, and decides carry on preparing a completely different dish.
Surely the right thing to do would be to prepare the meal that the customer wants!

Even if that was the case (nothing better that DEVONthink could do), it would also be very useful if it informed the user that the item was saved in a different format.

Sometimes, mainly due to the complexity of the source web site–and many have that complexity I suspect is to prevent taking a PDF copies or to make the web page super cool–DEVONthink will do the best it can in the circumstances. When I see that happen, I use the “Open with Safari” command on the bookmark and try again.

I take most of my copies of interesting web pages using using the Print command in Safari, then picking "Save PDF to DEVONthink, not using the clipper. So on problematic web sites you may try that.

Any URL that reliably fails that way? Which browser and which version of macOS? And how exactly do you clip to DEVONthink - via the browser extension, the sharing extension, a bookmarklet or by activating the Sorter? And finally, clutter-free or not, single page or paginated PDF? All of this might matter.

Any URL that reliably fails that way?

No. For me it’s about 80% of initial attempts across a variety of sites. It always works the second time.

Which browser and which version of macOS?

I reported earlier I saw this on Devonthink 3.9.4, Firefox 121.0, macOS 13.6.3. I’m currently on
Devonthink 3.9.4, Firefox 124.0.1, macOS 13.6.3.

And how exactly do you clip to DEVONthink - via the browser extension, the sharing extension, a bookmarklet or by activating the Sorter?

“Clip to DEVONthink” extension version 1.5.2. See the video I posted:

And finally, clutter-free or not, single page or paginated PDF?

I do PDF (one-page), not clutter-free. I just reproduced it with Paginated.

I always re-do the same webpage after it fails (saves as web location). But I just tried it with a different tab on the second attempt. Tried to save tab A as PDF, it gave a web location, I switched to tab B and tried to save as PDF, it correctly saved as PDF. I switched to tab C and it correctly saved as PDF.

Is it possible the process is in ‘App Nap’ or something? Are there any debug logs I can send you?

A URL would be useful nonetheless as I can’t reproduce this issue.

Does it work right after rebooting the computer and using Safari without any extensions? Do you use any Firefox extensions?