Douplicate UUID problem on sync after moving databases


I am using ProOffice on Macs and iOS. I had several databases that were originally (by default) stored in my ~/Documents folder. With the upgrade to Sierra, Apple decided to move that folder to the iCloud with the result that my iCloud storage ran out (plus hints of not storing database files in cloud folder). So what I did was close all databases and move all .dbase2 files to a new, again local folder and open them again.

But since then I have trouble syncing (to another mac and my iPad), since I am getting Douplicate UUID errors (no, it’s not duplicate, it’s the same database, stupid!) and run out of ideas. What can I do?

Thanks a lot for your help


Right-click the Sync location in DEVONthink’s Preferences > Sync and choose Clean Location. Then reSync afresh.

A screenshot of the exact error message might be useful.

I am having this same problem. My Log Window has a long list of one particular database with the message, “Duplicate database UUID” I get the same message on my phone. Any way I can look at the UUIDs of my databases to see which are duplicates?

Thank you!

I tried this but the “Clean” option is grayed out so I cannot select it.

Was there a solution to this problem? I am getting the same error message now…


@arne: Have you duplicated and renamed databases in the Finder?

Jim, not that I remember.
I remember having trouble with syncing via dropbox to the iPad, when I set-up synching, again. Now I always get this error message.
I was stupid enough to do something under time pressure, as I had very busy time and tried to find a quick fix to the syncing trouble. Now the database in question exists twice, but with different file counts…


Please start a Support Ticket. Thanks!