Duplicate Database on Second Mac

I opened an existing database on my laptop and added an indexed file. I did not duplicate, or create a new database. This morning I logged into my desktop and I have two databases with the same UUID and a log file populated with “Duplicate database UUID.” entries.
I checked my Finder, and there is now a second database file in my home folder with the same name, that only contains the new indexed folder. The original database is in my home folder in a folder called “Databases” with all my other databases tucked in.
I will move the folder over to the right database and “Clean” the new one, but I don’t know why a new database was created in this scenario.
I am using CloudKit Sync. DTG3

I saw this entry: Douplicate UUID problem on sync after moving databases - But it still doesn’t explain why a new database was created.

It shouldn’t. Did you rename or move the existing database while it was in use?

I did not. I just added a folder to index. That was my only interaction.

What’s the full path of the indexed folder?


A screenshot File > Database Properties… of both databases might be useful, thanks.

I already moved and cleaned the duplicate database and everything seems to be working well.

The other one would have been Home Folder > Suitcase.dtBase2.

Is a verification of the database successful?

Yes it verifies.
Everything is back to normal now. I am sorry I fixed it before you could test it.

I am just wondering if there was something that forces a database to the home folder even if the existing database is in another.

So far this is the first report of its kind ever, therefore please let us know if this should happen again.

I had a similar issue when updating Indexed files & folders after adding a file to one of the Indexed folders: duplicate files listed. In fact, the Index showed multiple duplicates. This was a couple of weeks ago now, and I corrected it by rebuilding the database and deleting the old database. I only report it now to let you know that this is not a completely isolated event. Mac-Mojave10.14.6, DT3.6.3

Thanks for the info! However, this is a different issue actually. Certain actions can indeed cause duplicates but it’s hard to tell without additional details or screenshots what exactly happened.