DT 3.9.1 OCR/PDF conversion no longer works

Since the DT 3.9.1 update, the OCR/PDF conversion no longer works for me. The conversion process starts but no new PDF+Text file is created. No error message appears. Before the update it worked fine. MacOS 13.4, MacBook Pro M1

Please check if an update of the OCR engine is available (see DEVONthink 3 > Install Add-Ons…).

No, it is grey.

Just a thought. Have you tried a few PDF’s or just one? A PDF you created or from some other source? Could the PDF(s) be non-standard or otherwise corrupted or something? Some PDFs are not really up to spec.

Yes I tried with a few PDF’s from different sources.

Able to copy one here so others can try?

TIFF to PDF+Text works, but PDF to PDF+Text not. The PDF’s are normally from ExactScan and this works before. Tonight I can send a PDF

Here is a copy of a PDF. It looks like the file is not saved after conversion.
Scan-001.pdf (203,2 KB)

Works fine over here. A screenshot of Preferences > OCR might be useful. In addition, what’s the version of ~/Library/Application Support/DEVONthink 3/Abbyy/DTOCRHelper.app?


Date of the DTOCRHelper.app is: 25.03.2023, where can I finde the Versionnumber?

E.g. via the Finder’s Info panel.

OCR to “Searchable PDF” works fine here with 3.9.1, also. (I know this doesn’t directly help you, but …)

Version DTOCRHelper.app is 1.1.23

OCR to RTF or Word works fine, only OCR to “Searchable PDF” not.

I have exactly the same issues with 1.1.23.
After scan with ExactScan Pro from a Kodak i40, only “OCR to searchable PDF” does not bring the file to its destination - the other variants work.

Now it works again on my system.
I deleted the folder → Library>Application Support->Devonthink 3->Abbyy
Then installed Devonthink again.
Abbyy-Folder seems to stay away under that path but the other ABBYY folder was updated during the installation → Library>Application Support->ABBYY and OCR works again.
May be a solution!?

1 Like

Oddly, the version I have on my iMac is 1.1.18 vs. 1.1.23 @philius and @OlafR have with DEVONthink 3.9.1 installed.

Seems to be some sort of update issue?

Sorry, but it does not work with what I did above.
The PDF seemed to be OCRed by Abbyy but this was not right.
I started conversion of a not searchable PDF to searchable PDF - then ABBYY was downloaded and installed again, asked for access to Desktop and Documents but now the original issue remains.

So ABBYY might be the problem…

Hold the Option key and choose Help > Report bug to start a support ticket.

The Intel & ARM versions are not the same.

1 Like