DT3 Beta4 Smart Rules bug


Problem 1

When I attempt to Search in Inboxes, it just selects the global inbox for running smart rules. According to my understanding, it should also include the database specific inboxes.

Problem 2

I am attempting to add the Sortable date as a prefix to files in my inbox. Please see picture. However, sometimes the files that are in my inbox already have the date prefix added. I am trying to make the smart rule recognize if there is the year 2019, then the file is already prefixed correctly and so the rule can be omitted. Please see my attempts below using wildcards and NOT boolean statements. What am I missing here? Thanks a bunch :smiley:

I believe that “begins with” does not support negation operator and “Name is not” is a direct string comparison. The developer also mentioned that “Only the “matches” option supports boolean operators & wildcards, all other options are plain string comparisons.” See this thread: # A few questions on negation operator for Name and others

Thanks @ngan for the help!

I was able to solve my second problem with the command Name… Matches… NOT 2019.

Problem 1 is still unresolved however :smile:

For problem 2 this is just an idea from a mere beginner (so forgive me if it’s not helpful)…

Why not have a rule to identify filenames that contain or start with the 2019 date string and which then move the file appropriately to the correct database and folder. You could then use a separate rule, lower down the list of smart rules, to identify and rename other files (i.e., which don’t contain the 2019 date string). Would that work (even at the expense of creating an extra rule)?

Edit: sorry, I saw your response only once I’d posted this.


Global inbox is technically a separate database. So, my guess is selecting global inbox does not automatically include other inboxes (you can see that only the global inbox is checked even when u select the top level inboxes). It is unlikely a bug, because smart rule/group in DT3 don’t allow user to select more than one group in a single filter except for “all databases”. So, selecting global inbox and other inboxes is equivalent to heterogenous groups selection.

Perhaps you need to setup multiple smart rules (just duplicate the rules), one for each inbox, to do the job u need (just one option that comes to my mind).

Thanks for the tip with duplicating the smart rule. I thought of that as well.

If DEVONthink is deliberately set to not have the ability to select multiple inboxes as part of one smart rule, so be it. However, I think it could be misleading, let me explain.

Smart rules are set as Search in Databases by default. A user wants to change that, and when they expand the options, they see Inboxes as a selectable option (complete with child listings indented to show their hierarchy). A person could easily make that mistake (as I have done).

If this is deemed to be a problem, a couple ideas are to enable selecting all inboxes. Or maybe differentiating Inboxes slightly from the child listings below (greying out) so that it is clearer.

In any the case, kudos to Devonthink for giving us this great program with its amazing versatility :smile: It’s amazing the amount of care and forethought that has gone into it.

I am thinking it’s a small bug, since Inboxes are segregated on purpose - as the incoming vector for all open databases, but @cgrunenberg would have to assess this.

(And yes, it makes sense to me that you can select Inboxes to just isolate those items.)