DT3 Pro Scanners Not working

Using DT 3.0.1 on MacOS 15 ( Latest Catalina Printer Scanner Drivers Installed)

Scanners (HP and Epson) are recognised by DT but unable to scan with error… “Action Required Failed to Open a Session on the Device”

We are currently looking into this issue, I will update you when we have a solution

I’m facing the same issue with HP Envy 7640 All-in-One-Printer: the scanner is recognized by DT 3.0.1 under Mac OS 10.15 Catalina, but impossible to scan with error message like reported above.

I am facing the same issue with my HP OfficeJet 8710.
In previous DT3 Versions scanning was possible without any issue.

I have the same issue (HP MFP M277DW). If I use the image capture app in Catalina I can scan, but in DT3 it is not working with the mentioned error.

Scanning in DT 3 was possible before upgrading to Catalina.

@amcd @Philippe @micste @devnull

Not sure if your workflow is interrupted. I presume Catalina still supports folder actions. This could be an automated work around while you are awaiting a solution.

  • Install the folder action in the add-on menu
  • Create a directory on your SSD/HDD for incoming scans
  • Scan a document to a file in this directory
  • Right click on the folder and open the folder action dialog
  • In the macOS dialog enable folder actions and attach a suitable script like import and OCR

Following scans to this folder will be automatically imported and OCR’d.

I have had a direct email exchange with DT Support but seem to be a little stuck. Now I know this is not a unique problem to me…

I have Epson and HP Scanners, all exhibit this problem.

I have uninstalled and reinstalled DEVONthink 3 Pro.


  1. I installed macOS-15’s first update released today.
  2. This reported a new scanner driver for my V800 Epson Photo Scanner…. I installed it.
  3. Then I went to the HP link provided by DT and installed the macOS 15 driver and app update from HP.
  4. The HP website confirmed this was a specific macOS 15 driver update.
  5. I have spoken with Apple support and they confirmed via remote login to my Mac that I have the latest macOS-15 drivers for HP and Epson.
  6. I described the problem with scanning and they have again referred me back to DEVON Technologies

SO ALL of my printer/scanner drivers are specific for macOS 15.

HOWEVER….I still have the same problem with DEVONthink 3 Pro (see previous screenshots) I cannot import scans from either HP or Epson Scanners.

As I mentioned before other third party apps like PDFpenPro, Epson Scan 2, and macOS-15 Print/Scan allow imports from scans just fine.

Having followed all steps you have suggested I now feel that the problem lies in the DEVONthink 3.app

Please escalate this to your developers . Perhaps your integration of Apple’s… Image Capture.app or driver locking mechanisms need to be looked at as it appears all scanners are locked out by DT-3.

cheers… amcd

Have you tried my work-around? Does this import problem interrupt your workflow, or is it just a nuisance?

I haven’t moved to Catalina yet as I more or less anticipate on these kind of hiccups with a new OS version. My workflow would certainly be hampered if there was no automatic import mechanism possible when I do migrate though.

Looked at your suggestion. Catalina has a Folders Action Service but does not seem to have a suitable script to apply to the Folder. These are the available scripts. See attachment please.

DT supports has now replicated the issue which they suggest is “The root cause is an issue with Apple’s scanner interface reporting incorrect status”.

They are workington the issue.

I have found that a similar issue exists with Readiris OCR and HP Scanning.

thanks amcd

Catalina has a Folders Action Service but does not seem to have a suitable script to apply to the Folder.

That’s strange. As I understand from the automation chapter of the manual (undoubtedly written by @BLUEFROG) the scripts should be installed automatically

You can manually re-install them however. Choose DEVONThink > Install Add-Ons. It’s the fourth checkbox from above.

After installation several scripts should be available in the menu, among which is Import, OCR and delete. You can check the installation in the folder ~/Library/Scripts/Folder Action Scripts (the Library folder is hidden by default in macOS).

I primarily use these scripts to have macOS take action upon a network folder that my scans end up in. But it should also work with cable attached scanners and local folders.

1 Like

I am getting this with a Canonscan LIDE 220 and an Epson Workforce WF-7520. “Failed to open a Session on the Device.”

1 Like

Running Catalina, right?

Yes no problems under Mojave… This is a Catalina Issue. DT have told me they are working on the problem.

Yes, scanners not working under Catalina and Devonthink 3

As noted: This issue is under investigation at the moment.​ In the interim, you should be able to scan with the external scanning software then import the files afterwards.​ If you haven’t done OCR externally, you can use ​File > Import > Images (with OCR)​.

I got an Epson Scanner/Printer too and, not surprisingly, I cannot scan from DEVONthink either since I had upgraded to Catalina.

I just want to add that it is not only possible to scan from the macOS Printer/Scanner preferences, Epson Scan 2 (released just before Catalina), and certainly third party scan apps. Scanning from the scanner to a computer works too.

Epson printers have three scan “buttons”, JPEG, PDF and E-Mail. While the titles of these buttons cannot be changed they can be programmed to one’s needs.

For example, I have set JPEG to save the scan as a TIFF file to my Downloads folder (I would have prefered PNG but that is not offered). I have set PDF to save the scan as a PDF to my Downloads folder. And since I almost never scan directly to an E-Mail I have set E-Mail to save the scan as a PDF to DEVONthink. The software allows to either save to a folder, the DEVONthink Global Inbox in this case, or to an app. The latter option opens for each scan DEVONthink’s import HUD to pick the destination.

This plus a smart rule to convert the scanned PDF into PDF+Searchable Text works pretty well. At least for full page scans.

As to why there is a problem with Epson scanners what comes to my mind is that the last remaining software that gave me the annoying 32 bit warning on Mojave was Epson’s. I contacted support and was told that there were both 32 bit and 64 bit apps and drivers installed already and therefore I should not worry.

So I wonder if there might be some remnants of the old and now inactive Epson software and DEVONthink somehow tries to connect by them to the scanner.

DT3 is still not working on all 3 of my scanners (Epson and 2 HP).

I have an alternative OCR (Canon Readiris Pro 17) which exhibited the same Catalina problem as DT3. Readiris have now fixed the problem and all my scanners work with it. But Readiris is not as good as DT3 OCR.

Is there any news from DEVONtechnologies on this issue???

As I said, it is under investigation.

1 Like

Got the same as well with the Epson Workforce - running on Catalina
After the upgrade to Catalina, it stopped working with “Communication problems”.
The scanner can be contacted by the original Apple tool “Digital Pictures” and delivers scans.

Thank you!