DT3 with ix500 and Scansnap Home - Setup problem

Hi everyone.

I am new to DT and want to migrate from Evernote to DT3.

Currently testing the new beta and I am already on board. Unfortunately I cannot connect my ix500 following the instructions given. Enabled Devonthink in the Preferences/Applications in ScanSnap Home but cannot find it under Applications when I try to set up a new profile. I know there is a bug and it should eventually hide unter a blank entry … alas … there is not even an applications section at the bottom. Only the Scan Snap Cloud as last entry.

Any help appreciated.

In the window where you were expecting to see an “Application” entry (“Add new profile” is the window title) instead choose one of the templates on the left (e.g. “Auto scan”); now, at the bottom of the right hand side of the window (scroll down, ant then directly above the cancel button) you will be able to choose the application (in this case DEVONthink). Alter any scan settings you want, then click “Add” - you’re done.

1 Like

That worked for me. Thanks a lot.

The bug btw means that when you now scan to DT3, it will not treat the incoming file as a scan, ie will not OCR it, even if the appropriate setting is set - apparently that is fixed in beta 2. Other than that scanning to DT3 with an ix500 using ScanSnap Home works fine (to the extent that ScanSnap Home is not a fine piece of software IMHO).

You’re most welcome, glad I could help!

Sad but true

That said (and agreed), the new(ish) ScanSnap “Home” is light years ahead of their previous software offering…

OT, but I disagree - or can’t operate the software properly. ScanSnap Home insists on keeping the scan after handing it on to a third party application; data protection principles don’t however allow me to keep multiple copies of documents - so after scanning to DT via ScanSnap I have to open the ScanSnap software, delete the scan, and then empty the trash in ScanSnap. Even if you succeed in getting DT to delete the original file, ScanSnap still has a relatively high-resolution thumbnail of the file, which again, I cannot keep… at least the old software just scanned rather than pretending to be a document manager… if anybody comes across a solution, do let me know…

When you set up your DEVONthink profile in ScanSnap Home, just clear the “Manage in ScanSnap Home” checkbox.

This worked for me in DTPO, but I have admittedly not yet tried to scan anything to DT3, so maybe things have changed.


well, Mr_V, this is me declaring my (totally IT-centric, platonic) love for you! Was that checkbox always there? It seems sort of obvious really - works a treat! Thanks for that, you’ve saved me a lot of work!

1 Like

Hahaha, I’m happy that it makes your life easier!

I have to admit that I don’t know whether that checkbox had always been there since the first version of ScanSnap Home. At first, Home always saved thumbnails for me and the fact simply didn’t bother me all that much. I only found that checkbox after some time using the app!

When you set up your DEVONthink profile in ScanSnap Home, just clear the “Manage in ScanSnap Home” checkbox.

I think this is a recent update. I have to test this out here, but that will be a good answer for people who have complained about DEVONthink not cleaning up the ScanSnap software’s files.

I have a similar problem, but it’s with the older ScanSnap Manager software (v 6.3L70). My ScanSnap is old, too (S510M).

Even though I have it set to Scan to DEVONThink 3, it still insists on saving a duplicate file in the ~/Pictures folder, which I then have to go back and delete manually. I can’t find a way to disable it ;-(

Any thoughts?

I think you may be right.

However, all is still not 100%. I’ve just noticed by chance that the documents I scanned recently are still in the ScanSnap Home folder! In the past, ScanSnap home collected metadata and thumbnails, but no actual documents remained. Now the opposite is true. :frowning:

That said, I’ve changed a couple of things on my computer recently:

  • Update ScanSnap Home (twice)
  • Started using DEVONthink 3 beta
  • Unchecked the “Manage in ScanSnap Home” checkbox

I’d have to go back and vary these variables one at a time — as far as possible — to see what caused the change in behaviour.

Where is this checkbox? I couldn’t find it.

Thank you.
It is unchecked & greyed out for some reason on my Mac

Just want to ask a naive question. What are the additional value in integrating the Scansnap s/w with 3.0?
Can’t users just set the destination of Scansnap or any scanner to an index macOS folder, and let smart rule to take care of everything, such as OCR and import to different groups in 3.0. In fact, that what I’m doing now. I just user my printer to wirelessly scan to an index folder on my Mac, and let smart rules to do all the jobs for me.

@VictorGav: In the DT3 preferences you can set up what DT does when it receives a file from a scanner (the tab is probably called “OCR”, but I’m OOO, so I can’t check just now - will update this post if necessary). One of the things you can set here is what to do with the original document (in DT2 the checkbox is “move to trash”). In DT2 this reliably worked for me - wherever ScanSnap was saving to, the original file was deleted by DT following OCR. Because there is a bug in DT3b1 and OCR is not triggered when a file arrives from ScanSnap I could imagine that the second step - deleting the file - might not be triggered either (disclaimer: I know there is a bug when using ScanSnapHome, but don’t know if it applies to the ScanSnap Manager too). So: check whether you have the appropriate checkboxes ticked and if yes, waiting for DT3b2 might be the answer.

@Mr_V: I’m out on a limb, guessing here: ScanSnapHome (SSH) has always placed the scan in a folder, as set in the scanning preferences. Previously, SSH then passed the scan to DT2, which - if set up to do so - performed OCR and then moved the original file (which SSH had saved) to trash. Because of a bug in DT3b1 OCR is not automatically triggered even if appropriately set up; presumably the second step (move to trash) is also not triggered, which is why you are finding a copy of the document in the SSH folder.

ie: SSH always saves the file to the folder designated in the scan preferences. The “manage in SSH” checkbox only influences whether the file (and its thumbnail) is visible/managed in SSH. The file would usually be deleted by DT3 (even if the file is managed by SSH, actually, meaning that only the thumbnail [and possibly other copies of the file in temporary folders, library, wherever…] remains in SSH if DT is set up that way).

@Blanc I think we’re all guessing here. :frowning:

I’ll try to do a few tests this afternoon when I’m at home with my scanner again…