Error: AsyncSocketErrorDomain 2

Does anyone have the same issue with local sync:

Fehler bei der Initialisierung des Speicherortes “xyz@xyz”
Attempt to connect to host timed out (AsyncSocketErrorDomain 2)

It’s a one way problem!

Solution? Thanks a lot in advance!

Problem solved! It was a local network issue!

Could you share what you found? Thanks

I’m also experiencing this same exact error today. Any assistance or suggestions would be helpful.

I experienced the same issue with Devonthink 3.0. Reseting my Mac and iPad also the local network wifi doesn’t solve the problem.
By Devonthink Pro Office version 2, I don’t have any problem.

The Bonjour sync of version 2/3 is basically identical. Does the firewall block DEVONthink 3?

1 Like

Thanks.
Thats true. I edited the firewall setting for incoming connections and problem fixed.

I have the same issue. Where and how do you Setup the firewall? - 2019121712

See System Preferences > Security > Firewall

In my case, it was an issue with LittleSnitch (it is a “firewall” app)!

1 Like

Thank you.

I wrestled with this error and finally (by tweaking anything and everything) found that in the “Security and Privacy/Firewall/Firewall Options” preferences on my Macbook, even though “Allow incoming connections” was granted to DT3, I also had to uncheck “Enable Stealth Mode.” I was immediately prompted to enter my Bonjour sync password and was back in business. Relief.

Thanks for this follow-up. Good to know. :slight_smile:

1 Like

Hi all,

when i faced the same issue described in this thread,i checked all the recommendations posted here without success. Here are the details of my configurations:

DT 3.6.2 on a macbook pro
MacOS 11.2.1
iPad Pro
DT TG 2.7.9 and 3.0.3 (same behaviour)

I am using a local sync store on an iMac. Preferrably i would like to sync my iPad via local network with the DBs on the iMac. I understood that this will not work. So i tried to use bonjour to sync directly with the macbook. So i enabled bonjour in DT3 on my macbook. The iPad recognises the macbook, it tries to connect and ends up with

"Fehler bei der Initialisierung des Speicherorts. ‘<my-user-name>@macbook-pro.fritz.box’. Attempt to connect to host timed out (AsyncSocketErrorDomain 2)“

DT3 is enabled in Firewall settings, Stealth mode is disabled, Little Snitch allows connection for DT3 to (i also tried it with LS switched off)

Any help highly appreciated. Thanks

Delete all sync options on all devices and start a new sync. That was in many cases the solution for my sync issues.

You can also try to enable bonjour sync only on iPad an connect from your Macbook to you iPad…

indeed the direction macbook 2 iPad works. But this is not an option for me. Will try your advice to reset all sync options …

… not sure if tjur’s tip was the reason for successful sync. I just switched off all syncing in DT 3. That did not help … initially. I found out that the local sync store did not run because the macbook was not connected to the iMac. After the local sync store was updated the iPad started to ask für password and sync’ed.

Thanks for support, tjur!

1 Like

By the way, it doesn’t matter which direction you sync…

1 Like