How does batch process "Change Name" action helps me to change the underlying filename of a document?

I want to solve How can I change the FILE name of a document with double extensions with a batch process. So I’ve read Bluefrog’s Rename extension on many receipt PDF’s.

But when i try it out I still have probelms. Staring situation is a document which looks in DT3 like this:

In the file system it looks like this:

Now I want to create a Batch process which changes the file name so that it has only one “.pdf” (because I have quite a few documents where the file name ends with “.pdf.pdf”).

I started with the Batch process actions from Bluefrog’s post (using the * placeholder):

But somehow this does nothing (neither to the name nor to the underlying file). Then I tried using the File Name placeholder:

This does change the underlying file to one extension:

DT Extension Cleanup_Screen Shot 2022-09-02 at 12.44.26

So far so good - but it adds to the document name the extension as well:

So my question is: How can I add now some action to the Batch process, so that the document name changes to no extension? (And the filename still has one extension.)

Many thanks for any pointers!

The name does not include the extension. The easiest way to fix this is by renaming the file. E.g. like this:

This uses the aliases to store the original name temporarily.

Why are you trying to remove the document’s extension?

If you don’t want to see them in the item list, have you disabled Preferences > General > Appearance > Show filename extensions?

Yes, Show filename extensions is unchecked:

Storing the Name in “Aliases”: works. Thanks!

Should I somehow clear the “Aliases” field afterwards?

The last action on my screenshot clears the aliases again.

1 Like

Ups, yes, of course! Sorry for my oversight: In true dummy’s confidence I thought this line might be just an unintended left-over… Thanks for patiently point me back to it!

One question though about it – for me the following happens: After I ran a Batch Process with the last Change Aliases action set to empty and I open The Batch Process dialog again, everything is pre-filled with the actions of the run before – except this last line: It is always filled with “Aliases”.

Why’s that?

Empty fields are replaced with certain default values. If you need these actions regularly, you could also create a smart rule with the same actions and use it on demand (e.g. via drag & drop).

1 Like

Makes sense. Thanks.

Another possibility is to just enter a space when changing e.g. aliases or URLs. DEVONthink automatically trims spaces anyway.

Good idea. Thanks a lot.