How to change default weblink click to open Safari rather than DEVONthink Browser?

(I’m a DEVONthink newbie; maybe this is in the help or docs but I couldn’t find it).

When reading an RTF note in the DEVONthink preview pane, when I click on a weblink, it opens the weblink directly in the preview pane using the DEVONthink web browser. I would like to change the default behavior to open the weblink in Safari immediately rather than having to Right Click the link and pull down to Open with Safari. I want my click to open Safari immediately (and NOT use the DEVONthink web browser ever).

Why? For many of my web links, the DEVONthink preview web browser opens to a Log In page. Many of my web links are to news sites (e.g. NY Times) that require logging in. Even this DEVONthink discourse forum requires a Log In page. And, in Safari, which is always open for me, I am already logged in to the news sites and user forum sites I regularly use. So I don’t have to log in again (or, even if I did, Safari inserts my login credentials, whereas the DEVONthink preview web browser does not).

Is there a DEVONthink preferences setting to “click directly to Safari and never to DEVONthink browser”?

Preferences General > Click on links opens them externally

1 Like

Thanks, @pete31. It was right there, but I didn’t see it because I was looking for “web links” or “browser”. Sometimes my eyes skip over the obvious :blush:.

1 Like

Follow on question: the preference choice “General > Click on links them externally” works great. Clicking now opens a tab in Safari as desired (thanks, @pete31).

Is there a way to also have Safari become the front window? When I click on a weblink in other Mac applications, the link opens in Safari AND Safari becomes the front window. When I click on the weblink in DEVONthink, the weblink opens a Safari tab, but the Safari window remains behind the DEVONthink window. I am surprised that DEVONthink is behaving differently than my other Mac applications in this regard. Can I change that behavior?

I’m not sure (and can’t test it) but maybe it’s the same behavior as described in thread Bug ? behaviour of mailto: different with RTF and HTML.

1 Like

I just tested this by clicking a weblink in 3 copies of the same note in 3 DEVONthink formats: RTF, Markdown and Formatted Note. In all 3 formats, clicking the weblink opens the link in Safari but DEVONthink remains the active app with Safari behind it.

Use shift-clicking to activate the app which handles the link.

1 Like

This works perfectly. Thanks, @cgrunenberg. Does it appear in the documentation anywhere? I’m trying to learn (I’m a complete newbie) where to find info.

Yes. Can’t test right now but it should be something like Help > Documentation > Appendix > Preferences: General:

Click on links opens them externally: Enable opening links in document text in the system default application. Use ⇧-click to open and activate the default application. Note ⌘ or ⌥-clicks can be still used to open links in new tabs or to add them to the Download Manager, respectively.

You could use this script to index a duplicate of DEVONthink’s help. Searching an app’s help content from inside DEVONthink is far easier than searching inside the macOS help viewer (at least for me).



I believe it would be much more intiutive to make Safari window active by default (without Shift click) if “Click on links opens them externally” setting is checked, and leave DEVONthink window active when I Shift click. (Because Shift key should change the expected action)

Currently I find myself clicking links multiple times, because I don’t realize it is opened in background since I expect some reaction to my click, but nothing happens on my screen.