How to stop Chrome from asking permission to access DT#

Does anybody know how to get Chrome to stop asking for permission to open DT3 every time I use the clip extension? Very annoying.

That would be a Chrome support question. And you could just stop using Chrome :stuck_out_tongue:

Actually it is a question about the DT Chrome Extension and since this is a user forum I was trying to find out if anybody else was having this issue and if so, how they solved it.

And no, for other reasons I cant stop using Chrome.

Same problem here

I have unfortunately not found a solution

Does the Clip to DEVONthink bookmarklet (see also cause this warning?

Yes- it gives the identical warning.

Question - A workaround for a similar issue with the Reminders app is to execute Applescript from external to DT3. I wonder if something similar might work here.

Is there a way to call Clip to Devonthink from Applescript and have that script retrieve the current URL in the active Chrome window?

In case of Reminders this is a security setting of macOS (see System Preferences > Security > Automation), in case of Chrome it’s an alert of the browser.

But instead of using the browser extension you could also click on the Web Clip tab of the Sorter and choose Chrome. Or use a system-wide hotkey for clipping, see Preferences > Sorter.

That works nicely indeed - it is a reasonable workaround.


Ok…both of those alternatives work well and not sure why I did’t try them…habit I guess. The hot key is really nice.