I don't own DDTG, yet it uploaded 41.3 GB into iCloud, breaking it

Is it safe for me to “Delete Documents and Data?”

Here are my databases—less than 6 GB total:

Safe in what way? What are you thinking may happen?

PS: What about the size of your Global Inbox?

Hello! Thanks for responding.

Afraid that it might cause a problem.

Well, I went ahead and did “Delete Documents and Data.” I expected that it would erase all DTTG data, since I do not own it. I assumed that DTTG and DTP are separate, but could not be sure.

Instead, it only deleted SOME data:

Then the feared side-effect happened: I have gotten 128 of these errors in the last 90 minutes:

Does this mean that syncing is no longer working?

Yep, it looks like syncing is broken, and that the DTTG widget inside Sys Prefs > iCloud really is necessary for DTP syncing. Can you explain what is going on, please? And how do I restore proper syncing?

Size of Global Inbox: 274 MB.

My iCloud was < 5 GB for the last 2 years. This jump to 49.2 GB just happened TODAY. And it’s tied to the DTTG item inside System Preferences, which I guess is your universal sync program, since I do not have DTTG.

What is listed as DEVONthink To Go in the System Preferences is not the sync engine. It’s just the sync store and what macOS calls it.

Well, I went ahead and did “Delete Documents and Data.” I expected that it would erase all DTTG data, since I do not own it. I assumed that DTTG and DTP are separate, but could not be sure.

Devices and sync locations are separate entities.

  • If you delete a database in DEVONthink To Go or DEVONthink, it does not remove sync data in the sync location.

  • If you delete the sync data, it doesn’t affect the local databases on the Mac or iOS device.

Instead, it only deleted SOME data:

You’re likely still syncing DEVONthink or DEVONthink To Go, so there still would be sync data in Apple’s servers.

Thanks. What about my the “19:52:00: iCloud (iCloud <Can’t create folder of database “New”, path exists already.” problem? “New” is no longer syncing. How do I fix this?

In DEVONthink’s Preferences > Sync:

  1. Select the sync location
  2. Control-click the database, hold the Option key, and choose Verify Database Thoroughly.

What is reported in Window > Log after the process is done?

Hi there. It says: “20:12:06: iCloud Database “New” successfully verified.”

10 seconds later, the Log showed: “20:12:20: iCloud(iCloud … etc.) Can’t create folder of database “New”, path exists already.”

I also did a Thorough Verify of the other two databases.

And of the Locations > iCloud.

And quit and restarted.

The Log is still producing the same error every 65 seconds.

Deleted the iCloud Location and recreated. Still getting the same error, and only with the database “New.” The others are fine.

Looks like I need to delete and reinstall/restart something. But what?

The DTTG widget in the Manage Store dialog (System Preferences > iCloud > Manage Storage) is growning again. My total db size is < 6 GB. My nurlsessiond has been running continually and it is now up to …

  1. Go into System Preferences > iCloud and click the Manage button. Select DEVONthink To Go then click the Delete documents and data button again.
    This preference doesn’t give a realtime view of the deletion process, so close and return to the Manage section occasionally to check the process. Once iCloud has removed the data from Apple’s server, the DEVONthink To Go entry will disappear.
  2. In DEVONthink’s Preferences > Sync, right-click the iCloud sync location and choose Clean Location. This will clear out any sync data.
  3. After the DEVONthink To Go item has disappeared from the system preference (and it will take some time), enable the sync in DEVONthink again.

Hello. I followed your instructions. It did not work. DTTG is again filling-up my iCloud Drive with god-knows-what. My total databases size is about 6 GB:

But DTTG looks is on track to fill it until an error occurs, again:

Are you syncing DEVONthink To Go in iOS?

No. I don’t own DDTG.

Is there any way I can INSPECT what is going on? What is this “data” that is being uploaded? And why?

The process is opaque to the user and not intended for casual observation.

It’s raw, chunked, DEVONthink-specific sync data.

OK. What the the deepest cleaning I can do? Which files do I need to delete to stop this constant filling-up of my iCloud Drive? My wifi is a slow 400 KB/s, but I’m already at 30 GB again:

It seems that, why ever, iCloud attributes the storage used by sync to DEVONthink To Go (which is weird, but a few things about iCloud are … remarkable).

How large are the databases that you sync through iCloud from your Mac? Do they match the amount of storage iCloud claims is used by DEVONthink To Go?