iCloud sync makes half the work


I use iCloud sync for my global inbox to have input docs from any device in the same place. Then I move them to specific databases via webdav.

IOS devices are iPhone and iPad Pro, Mc book Mojave and DT3 Pro.

when moved to an other place from iPhone or Macbook, the docs are not deleted from the global inbox on the IPAD. As if there had been a copy (I can find the doc in the other database) and not a move. any other way works (move from IPAD works fine, move from DT3 works fine on iPhone). just does’t work when IPAD is recipient of the sync.

I have the same DTTP settings on the Iphone and iPad Pro.

What did I do wrong?

Best Regards

Are any issues logged on iOS or the Mac (see Window > Log)? As iCloud is asynchronous contrary to WebDAV (and depends on Apple’s servers), this could also be a temporary issue.

No, no log neither on DT3 nor DTTP.
true I can wait but this has been this way for a long time now, and I think that sometimes it was still not deleted after several days. I can try to be patient this time and wait for some time before doing anything, but why would it be different on the iPhone?

thank you for you qick answer

Are you able to successfully verify the iCloud sync store on both the Mac (see contextual menu in Preferences > Sync) and on iOS?

Yes, I can see on both the devices.

1 Like

and by the way on the iPad he indicates a synchro on I cloud at 17:44

why would it be different on the iPhone?

Because the iPhone is a different device than the iPad or the Mac. Operations on one are no indicator of the operations on another.

This is generally true not only of Macs and mobile devices, but of things in general, e.g., a car from one manufacturer won’t run the same as another car from the same manufacturer. Each has an independent set of components and history affecting them.

Did you do the verification Criss asked about?

  • In DEVONthink To Go’s Settings > Sync: Locations , left-swipe the iCloud location and choose Verify Thoroughly . Check for the results by touching the sync icon in the bottom toolbar. And this may take a little time to finish.

  • In DEVONthink’s Preferences > Sync , hold the Option key , Control-click the sync location, and choose Verify Location Thoroughly .
    The results will be shown in Window > Log .

of course, my question on iPad/iphone was rhetorical, I am not an expert, sorry.
I did the checks Criss asked, sorry you couldn’t see the answer. I am following your instructions, because I didn’t know the thorough option. it is in progress as we speak, I keep you posted when done.

no issue displayed on the Mac. iPad still working

same for IPAD, no specific error message

No worries and thanks for the screencaps!

It is quite possible iCloud has stalled - a condition over which we have no control, nor can we even detect it. We can’t reproduce this issue, and some have said it “just started working!”

Here are a few things people have said “worked” , though we obviously can’t test it since we can’t reproduce it. I would try them individually…

  • Reboot the problematic device(s).
  • In DEVONthink’s Preferences > Sync , disable the iCloud location and quit the application. Relaunch DEVONthink and re-enable the sync location again.
  • In iOS’ Settings > your Apple ID > iCloud, try disabling and re-enabling iCloud Drive and DEVONthink.

OK I will,

I did the first on the both IPAD and Macbook,I did disable iCloud and re enable it, but not on the Mac yet, I will do.

I will try the last item. as well. I will keep you updated, maybe not before next week, have a nice week end.

Best Regards

I forgot, I have noticed that some of the menus on DT3 French version have not been translated, or sometimes poorly. Do you want a hand on this? I like your software and if it can be useful to you…and in case it is not clear this is for free…

I did disable iCloud and re enable it, but not on the Mac yet, I will do.

Bear in mind, I don’t have an support information on if this is a viable option for this issue. So consider this before doing it on the Mac. If you are using any of macOS’ disk management in the iCloud prefs, like Optimize Mac Storage, it’s possible the OS could do something unexpected.

Re: translation
Hold the Option key and choose Help > Report bug to start a support ticket with the things you notice are incorrect and I will diret you to the proper person. Thanks!

As a recent Catalina/iOS13 upgrader, I found if you have any iOS12 or earlier or Mojave or earlier devices still signed into iCloud, it completely messes up iCloud. Especially if you convert Reminders on Catalina and iOS13 and NOT on the others. They take days to sync after that, and mine took a week with multiple device deletions and a night where all my iThings and MBPs were signed out of iCloud to fix the problem.

If you have a situation like that, sign the older devices out of iCloud and leave them that way until you can update them. It may help.


1 Like

Ugh! :roll_eyes:
Thanks for sharing that.

Here I have exactly same situation as @xtophe 's .
iPad sync works fine, iPhone cannot sync with iCloud whatsoever.

Another thing is that same situation happened on Ulysses. Therefore I believe future version of iOS will fix this.

1 Like

Thank you for sharing, I am cautious with moving to Catalina yet, so will probably temporarily sync my global inbox via webdav as well, waiting Apple to fix the iCloud problem or the software I use to be Catalina ready.

your answers were precious to make my mind, thanks

Update: after upgraded to iOS 13.3 beta, DEVONthink to Go on iPhone start syncing with iCloud.

super, good news and thank you for the heads up (i’m not to much a beta kind of guy…)

Same issue here as well. iPhone will do an initial sync of database if installed form scratch. After that though, it claims it is syncing, but really isn’t.

Glad to hear iOS 13.3 is the potential fix, but also wonder if DEVONtech can patch something in the interim?