Import folders and attachments from (Apple) Notes - 0 added

macos 10.15.1
devonthink pro 3.01

As in the title, Notes import not importing - it has worked before.

System Preferences | Automation - Devonthink - Notes is ticked

I have tried un-ticking/re-ticking but no change.

Thanks for any ideas.

1 Like

The AppleScript support of Apple Notes on Catalina is broken but required for this feature. The next release will include a workaround.

1 Like

Ok, cool. :slight_smile:

Thanks for the quick reply.

So, I know you don’t forecast release dates.

But, would you recommend that I start moving my several hundred Notes one at a time or wait a week or so?


Just wait a little longer…

1 Like

thank you

And, it’s working again after the 3.0.2 update - thanks :slight_smile:

I’m on the latest version (3.02) and still seem to have the problem mentioned above…

Is DEVONthink 3 allowed to automate Notes, see System Preferences > Security > Automation?

Same problem on 3.02 for me. Automation for Notes is switched on. Still doesn’t work.

Which version of Catalina? Does it work after enabling full disk access?

Same problem on 3.02 for me. Automation for Notes is switched on. Still doesn’t work.
Catalina 10.15.1. Full disk access enabled.

Please choose Help > Report Bug while pressing the Alt modifier key and send the result to cgrunenberg - at - - thanks!

same problem here… I have already opened a support ticket (I am using Catalina and DTP 3.0.3

same issue here!

  • Is Full Disk Access and the Automation requests for DEVONthink 3 enabled in System Preferences > Security & Privacy > Privacy?
  • Are you using nested folders in Apple Notes?

both is activated in the settings. My notes are in folders (icloud) in the notes app (no subfolders in these folders)

But what about @josieduffy ?

I am also having the same issue here and I have checked for Full Disk Access and the Automation requests.

(sent a bug report to you as well)

maybe @cgrunenberg can comment on this, as he has announced a bugfix for this above?