Import PDF Direct from Web

I have search some of the forums, so apologies if this has been asked and answered. How can I directly import a PDF from a web site into DTP? I currently view it, save it, then import it. I am hoping there is a method to view then import without the intermediate save step.

Thank you

Take a look at the bookmarklets at

To install them, simply drag directly from that page onto your browser’s Bookmarks bar.

Thank you Bill.

I loaded the bookmark into Safari (3.2.1). However when I display the pdf I wish to capture in Safari then use the bookmark in the toolbar, there is a delay, then a tone indicating the capture did not occur. I have the preferences set to ask what folder/db to capture too, could this be an issue since I receive the dialog?


Try again. If the PDF does not appear, check the Log (Window > Log).

Nothing shows in the log. I am able, while viewing the pdf in Safari, to save the pdf to disk and import it. But I cannot use the PDF bookmarklet, it jsut makes a tone and then there is nothing in the log either.

I’ve just added one of our press releases and both bookmarklets (PDF & Paginated PDF) work fine. Could you please post the URL you’re trying to add? Thank you!

This PDF requires a login and DEVONthink (having to download the file on its own because Safari doesn’t provide access to its contents) isn’t logged in.

I am also having a problem with using the PDF bookmarklets. I am using Safari 3.2.1 and have tried both the built-in PDF viewer and with the Adobe plugin. In neither case can I import a PDF displayed in the browser into DEVONthink. I also have no messages in the log window after an attempt to import.

Here is a URL of a PDF file that does not require a password.



here it works with Safari 4.0 beta

I’ve just added the document using the PDF and Paginated PDF bookmarklets using Safari 3.2.1 and Safari 4.0beta. How fast is your Internet connection, is JavaScript enabled, what’s the destination (see Preferences > Import)?

My internet connection is T1 speed or better, I’ve tried from different locations.
Javascript is enabled.
I tried different destinations, select group and global inbox.

I also tried turning the OS X firewall off, still did not help.

I did find the following messages in the log files:
5/4/09 7:32:48 AM [0x0-0xbf0bf].com.devon-technologies.thinkpro2[2193] failed to find start of cross-reference table.
5/4/09 7:32:48 AM [0x0-0xbf0bf].com.devon-technologies.thinkpro2[2193] missing or invalid cross-reference trailer.

Same two messages every time I tried to use the PDF bookmarklet.

On a good note, a reboot seems to have “fixed” the problem. The bookmarklets are now behaving as expected.

Thanks for the help.


Using Paul’s Lenovo link, I still get the tone almost immediately after selecting the destination in DTP. My log (Window-Log) is empty.

I changed the preferences back to Global Inbox for destination. When I use the button at the Lenovo site, DTP steals the focus and then the tone occurs. Again, nothing in the log.

My link speed is greater than 10Mb/s. I have Java Script enabled. My machine has been rebooted many times.


Which version/edition do you use? Anything in the console?

I am using Safari 3.2.1 and DTPpb4.

No console messages.

Bad form replying to myself …

two messages appeared in the console:
5/4/09 11:10:58 AM [0x0-0x1a01a].com.devon-technologies.thinkpro2[290] failed to find start of cross-reference table.
5/4/09 11:10:58 AM [0x0-0x1a01a].com.devon-technologies.thinkpro2[290] missing or invalid cross-reference trailer.

Hope this helps,

I’m not sure what’s causing these messages, at least DEVONthink doesn’t log them on its own. Anything special about your system, e.g. haxies/input managers? Does a restart or system maintenance fix this?

Not that I am aware of, the machine is 2 months old. Running applications tend to include: Symantec AV, VPN client, Lotus Notes, NetNewsWire, Safari, Mail, and Adium along with DTP. I did a shutdown over night, tried again this morning with the same results. I also removed and reinstalled the bookmarklets last night to no avail.

These are from trying PDF and PDF-Paginated:
5/5/09 8:15:33 AM [0x0-0x26026].com.devon-technologies.thinkpro2[258] failed to find start of cross-reference table.
5/5/09 8:15:33 AM [0x0-0x26026].com.devon-technologies.thinkpro2[258] missing or invalid cross-reference trailer.
5/5/09 8:16:09 AM [0x0-0x26026].com.devon-technologies.thinkpro2[258] failed to find start of cross-reference table.
5/5/09 8:16:09 AM [0x0-0x26026].com.devon-technologies.thinkpro2[258] missing or invalid cross-reference trailer.

Symantec AV? I haven’t checked Apple’s user forum chatter about antivirus software recently, but there’s a pretty long history of glitches caused by some antivirus software, including Symantec’s.

Personally, I’ve never installed antivirus software on an OS X computer. I might be concerned about forwarding contaminated Word files to Windows-using colleagues. But then, they all use antivirus software anyway, so I’ll leave the scrubbing job to them.

A few years ago, in response to requests (largely from former Windows users) Apple provided free antivirus software to .Mac subscribers. Pretty much a disaster, as it screwed up a lot of computers.

If I needed to scrub contaminated MS Office files of Windows origin, I would probably look to the free ClamXav.

Viruses have not been a problem on Macs running OS X. Trojans that can do bad things could be a problem even on Macs, but require the user to download and install them. There have been reports of trojans included with software downloaded from pirate sites (perhaps a rough form of justice, as the downloader is participating in theft). I’ve noticed that C ocktail, an OS X maintenance utility that I use, now has a routine to look for and scrub known malware that may have been installed on a computer.

It’s prudent to stick to trusted sites to download material to your Mac. There are bad people out there. It’s also prudent to be discriminating about what is installed. In my experience in software support, there are far more people experiencing computer problems from poorly written hacks than from malware written for the Mac. On odds, the fewer the utilities you install that modify the code of OS X, the more stable your computer is likely to be.

Not sure going without AV is a good idea, besides it is a corporate requirement. Do the messages give the impression that NAV is causing the issue?